pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: gobject-introspection is like, the worst.

On 06/28/17 17:09, Joerg Sonnenberger wrote:
I have not seen a single instance of this in bulk builds on 7.0 with GCC
or 7.99+ with clang. It would be a starting point to understand if it is
a problem with the module loader or not.

I tried installing clang but ran into a problem.  Maybe you can help me.

from all the reading I did I wound up adding this to mk.conf:

PKGSRC_COMPILER=       clang
CLANGBASE=             /usr
HAVE_LLVM=             yes

I wasn't totally clear about the first two items so I added them to the environment as well. I then cleared out my object tree and built and installed a new kernel. That worked and I installed and rebooted. Then I cleared my object tree again andran this.

./ -M/usr/obj/ tools && ./ -M/usr/obj/ release

That fails with this.

#    create  libstdc++-v3/allocator-inst.d
CC=/usr/obj/tools/bin/x86_64--netbsd-clang++ /usr/obj/tools/bin/nbmkdep -f allocator-inst.d.tmp -- -I/usr/obj/destdir/usr/include/g++/backward -std=c++11 -D_GLIBCXX_ABI_TAG_CXX11= --sysroot=/usr/obj/destdir -I/usr/src/external/gpl3/gcc/dist/gcc -I/usr/src/external/gpl3/gcc/dist/include -I/usr/src/external/gpl3/gcc/dist/libstdc++-v3/libsupc++ -I/usr/src/external/gpl3/gcc/dist/libgcc -I/usr/src/external/gpl3/gcc/lib/libstdc++-v3/../libstdc++-v3/arch/x86_64 -I. -DHAVE_STDLIB_H -DHAVE_STRING_H -I/usr/src/external/gpl3/gcc/dist/libstdc++-v3/include -I/usr/src/external/gpl3/gcc/lib/libstdc++-v3/arch/x86_64 -D_GLIBCXX_SHARED -DGTHREAD_USE_WEAK -DSUPPORTS_WEAK -std=gnu++11 -std=gnu++98 /usr/src/external/gpl3/gcc/dist/libstdc++-v3/src/c++98/ && mv allocator-inst.d.tmp allocator-inst.d In file included from /usr/src/external/gpl3/gcc/dist/libstdc++-v3/src/c++98/
In file included from /usr/obj/destdir/usr/include/c++/memory:600:
In file included from /usr/src/external/gpl3/gcc/dist/libstdc++-v3/libsupc++/typeinfo:34: /usr/src/external/gpl3/gcc/dist/libstdc++-v3/libsupc++/exception:37:10: fatal error:
      'bits/c++config.h' file not found
#include <bits/c++config.h>
1 error generated.
nbmkdep: compile failed.

I'm not sure why it's even in the gcc tree.

D'Arcy J.M. Cain <> IM:darcy%Vex.Net@localhost

Home | Main Index | Thread Index | Old Index