pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Confused, in need of direction

Well, I reinstalled 7.99.66 from scratch, installed pkgsrc, did a “cvs update -dPA” then tried building meta-pkgs/xfce4 and got this error:

gmake[3]: Entering directory '/usr/pkgsrc/sysutils/libnotify/work/libnotify-0.7.6/libnotify'
  GISCAN   Notify-0.7.gir
Command '[u'/usr/pkgsrc/sysutils/libnotify/work/libnotify-0.7.6/libnotify/tmp-introspectbhv_8p/Notify-0.7', u'--introspect-dump=/usr/pkgsrc/sysutils/libnotify/work/libnotify-0.7.6/libnotify/tmp-introspectbhv_8p/functions.txt,/usr/pkgsrc/sysutils/libnotify/work/libnotify-0.7.6/libnotify/tmp-introspectbhv_8p/dump.xml']' returned non-zero exit status -11
[1]   Segmentation fault (core dumped) CPPFLAGS="-I/usr...
/usr/pkg/share/gobject-introspection-1.0/Makefile.introspection:155: recipe for target 'Notify-0.7.gir' failed
gmake[3]: *** [Notify-0.7.gir] Error 139
gmake[3]: Leaving directory '/usr/pkgsrc/sysutils/libnotify/work/libnotify-0.7.6/libnotify'
Makefile:418: recipe for target 'all’ failed

Tried the PKG_DEFAULT_OPTIONS=“-introspection” in mk.conf and got the same results.

May no longer be confused, but I’m certainly stuck.


On Mar 25, 2017, at 10:22 PM, coypu%SDF.ORG@localhost wrote:

> Likely running into the now infamous "gobject-introspection" problem
> that most packages seem to not build, but only to a few people, on
> netbsd-current.
> (PR pkg/51266, and some mailing lists posts)
> As a result someone made 'introspection' a build option on many
> packages, like gstreamer0.10. but that's only a workaround.
> You can add PKG_DEFAULT_OPTIONS="-introspection" to /etc/mk.conf to use
> this workaround.
> (All the people who had the problem so far seemed to be using old
> machines - I wonder if 'cpuctl identify 0' info will help the right
> person figure it out)

Home | Main Index | Thread Index | Old Index