pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cmake not MAKE_JOBS_SAFE?

  [cmake build trouble]

I also had trouble and tried to send this, but my logs were apparently
too big.

The basic issue seems to be that cmake has the notion that on netbsd it
shoudl use /usr/pkg/lib/libncurses.  I see this in a comment, and it
seems to be doing it, but I didn't find where it actually happened.
Perhaps if it used autotools to build we wouldn't have this problem :-)

"Joerg Sonnenberger" <> writes:

> Module Name:	pkgsrc
> Committed By:	joerg
> Date:		Sat Sep 12 15:15:49 UTC 2015
> Modified Files:
> 	pkgsrc/devel/cmake: Makefile distinfo
> Added Files:
> 	pkgsrc/devel/cmake/patches:
> 	    patch-Source_CursesDialog_cmCursesLongMessageForm.cxx
> 	    patch-Source_CursesDialog_cmCursesMainForm.cxx
> 	    patch-Source_CursesDialog_cmCursesStringWidget.cxx
> 	    patch-Source_CursesDialog_cmCursesWidget.cxx
> Log Message:
> Remove the need for ncurses, just a curses with libform is enough.
> Bump revision.

On netbsd-6 i386:
  cmake from 9/2 builds fine
  head fails finding ncurses (log at end)

This is when ncurses is actually installed (because other things need
it).  I haven't tried without ncurses installed.

=> Bootstrap dependency digest>=20010302: found digest-20121220
=> Checksum SHA1 OK for cmake-3.3.1.tar.gz
=> Checksum RMD160 OK for cmake-3.3.1.tar.gz
===> Installing dependencies for cmake-3.3.1
The following variables will affect the build process of this package,
cmake-3.3.1.  Their current value is shown below:

        * CURSES_DEFAULT = curses
        * KRB5_DEFAULT = heimdal
        * SSLBASE = /usr
        * SSLCERTS = /etc/openssl/certs
        * SSLDIR = /etc/openssl
        * SSLKEYS = /etc/openssl/private

Based on these variables, the following variables have been set:

        * CURSES_TYPE = curses
        * KRB5BASE (defined, but empty)
        * KRB5_TYPE = heimdal

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Tool dependency gmake>=3.81: found gmake-4.1nb1
=> Tool dependency ccache-[0-9]*: found ccache-3.2.3
=> Tool dependency checkperms>=1.1: found checkperms-1.11
=> Full dependency libarchive>=3.1.2: found libarchive-3.1.2nb1
=> Full dependency libexecinfo>=1.1: found libexecinfo-1.1nb1
=> Full dependency curl>=7.35.0nb1: found curl-7.44.0
===> Overriding tools for cmake-3.3.1
===> Extracting for cmake-3.3.1
===> Creating toolchain wrappers for cmake-3.3.1
===> Configuring for cmake-3.3.1
-- Looking for cbreak in /usr/pkg/lib/
-- Looking for cbreak in /usr/pkg/lib/ - not found
-- Build files have been written to: /u0/n0/gdt/NetBSD-current/pkgsrc/devel/cmake/work/cmake-3.3.1
CMake has bootstrapped.  Now run make.
WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package Makefile.
===> Building for cmake-3.3.1
Scanning dependencies of target cmsys
[ 82%] Built target CTestLib
Scanning dependencies of target ccmake
[ 83%] Building CXX object Source/CMakeFiles/ccmake.dir/CursesDialog/cmCursesOptionsWidget.cxx.o
[ 87%] Building CXX object Source/CMakeFiles/ccmake.dir/CursesDialog/ccmake.cxx.o
[ 87%] Linking CXX executable ../bin/ccmake
ld: cannot find -lncurses
Source/CMakeFiles/ccmake.dir/build.make:417: recipe for target 'bin/ccmake' failed
gmake[2]: *** [bin/ccmake] Error 1
CMakeFiles/Makefile2:1564: recipe for target 'Source/CMakeFiles/ccmake.dir/all' failed
gmake[1]: *** [Source/CMakeFiles/ccmake.dir/all] Error 2
Makefile:160: recipe for target 'all' failed
gmake: *** [all] Error 2
*** Error code 2

Attachment: pgp_2x5teSrPr.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index