pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: warning: subversion now at 1.6.2

Greg Troxel wrote:
>   On Sat, May 30, 2009 at 2:20 AM, Greg Troxel <> 
> wrote:
>   > I have committed an update to subversion 1.6.2 prepared by Jens.  There
>   > may be some trouble (probably not in packaging - but in 1.6 itself), so
>   > I advise people to tread carefully, especially on servers.  Please let
>   > me and Jens know of any trouble.
>   I think now it is no longer possible to install subversion and Apache
>   2.0 together, right?
>   subversion now forces the installation of devel/apr (apr-1.3.3), but
>   www/apache2 still needs devel/apr0. The option to compile subversion
>   without apr1 is gone. Or am I missing something?
> Yes, that's what it does now.  I thought that this was a change in svn
> 1.6.x to require only apr1, but now I'm not sure.
> Perhaps Jens can explain, or you could pull back the apr1 option from
> the previous package and try that.  I'll have a look as well.

subversion notes in it's INSTALL documentation, that apr-util is required.

> Subversion also depends on the following third-party libraries:
> * libapr and libapr-util (REQUIRED for client and server)

They don't talk about apr0 and AFAIK apr-util requires apr>=1.3.0.

Maybe the subversion developers list can say more - but I'd suggest to keep
out apr0 support.


Home | Main Index | Thread Index | Old Index