pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Bootstrap problem under Ubuntu Intrepid Ibex [SOLVED]

Ian R. Justman wrote:
I fixed this issue with the glibc 2.8 patch I found with some Googling, so this error does not come up anymore.

New problem:

I try to bootstrap again, and I'm still not getting everything working.

Under Fedora 9, bmake builds as it should, but then, it switches gears, showing this:

=> Configuring and building libnbcompat
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking build system type...

And just sits there as if it went off into Lala Land with the load accordingly pegged since gcc is still in the R state.

Under Ubuntu Intrepid Ibis, I get:

gcc -O2 -D_PATH_DEFSYSPATH=\"/usr/pkgsrc/bootstrap/work/share/mk\" -I. -I/usr/pkgsrc/bootstrap/work/bmake -DHAVE_CONFIG_H -I../../libnbcompat -I/usr/pkgsrc/bootstrap/work/bmake/missing -DNEED_HOST_CDEFS_H -DMAKE_NATIVE -DSIGNAL_FLAGS=SA_RESTART -Werror -I../../libnbcompat -c /usr/pkgsrc/bootstrap/work/bmake/arch.c
cc1: warnings being treated as errors
/usr/pkgsrc/bootstrap/work/bmake/arch.c: In function Arch_Touch:
/usr/pkgsrc/bootstrap/work/bmake/arch.c:1036: error: ignoring return value of fwrite, declared with attribute warn_unused_result

I somehow suspect the latter might be a distribution setting, but then, I dunno. I wouldn't know about the former (I don't use Fedora for any use other than the need to test something to confirm whether something isn't a distro problem).

Any insight would be helpful.



I tried a different approach per another message that was sent to the list:


The system bootstraps properly under Ubuntu Intrepid Ibis now. It still goes into Lala Land under Fedora, but I don't intend to investigate that one any further because I do not use Fedora with any regularity.

One thing I also had to do under Ubuntu is use some other shell, in this case, I used the Korn Shell (apt-get install ksh), though PDKSH (apt-get install pdksh) and ZSH (apt-get install zsh) also appear to work. I haven't tried any other shells yet, but I used the Korn Shell family to bootstrap pkgsrc on my Linux boxen.

Hope this helps.


Ian R. Justman
UNIX hacker.  Anime fan.  Any questions?
ianj (at)

Home | Main Index | Thread Index | Old Index