pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: more GNOME problems

Hash: SHA1

On Sat, 25 Oct 2008, Dan Engholm wrote:

Last quarter, I had some problems compiling the gnome package under NetBSD because of XFree86 not having xdamage and xcomposite. With some help from OBATA Akio, I did get the compilation to complete. I installed the resulting packages on my main machine and found it to be unstable, so I went back to the Q1 version. This time, I tried GNOME on my build virtual machine first and the instability was still present. Searching Google, I did not find a lot of information on this problem but one reference claims it was solved in gnome-desktop version 2.22.0. I started looking into version numbers a bit and became confused.

Alistair's announcement of pkgsrc-2008Q3 says that GNOME has been updated to version 2.22.3. meta-pkgs/gnome/Makefile says that it is version 2.18.1. Are we really at 2.22.3?

In any case, my main NetBSD machine runs in a Xen guest domain. As a result, I run a vncserver as its graphical display. .vnc/xstartup starts the GNOME desktop using this command:

  exec /usr/bin/ssh-agent -- dbus-launch --exit-with-session gnome-session

Once the desktop is up and running, I get occasional error dialog windows that say:

  There was an error starting the GNOME Settings Daemon.

  Some things, such as themes, sounds, or background settings may not
  work correctly.

  The last error message was:

  Message did not receive a reply (timeout by message bus)

  GNOME will still try to restart the Settings Daemon next time you
  log in.

Indeed, my chosen theme (crux) comes and goes with the interesting effect of narrowing my terminal window column by column. Also, response time is really slow while nautilus sucks up CPU time.

In desperation, I removed all of my .gnome directories so they would get regenerated. This had no effect other than to make me redo all of my customizations. (Next time, I'll make copies, first. ;-)

Has anybody else seen this sort of problem? Better yet, does anybody know what I can do to fix the problem?


I see the exact same behaviour. This bug is present since months.
I get the same message on startup and if i try to start it from the terminal it consumes an extere ammount of cpu power (the settings-daemon).

So anyone knows what could this be?

- --
When in doubt, use brute force.

Adam Hoka <>
Adam Hoka <>
Version: GnuPG v1.4.9 (NetBSD)


Home | Main Index | Thread Index | Old Index