pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Amaya 10 build error


It worked on my machine... maybe because I was doing it on amd64. Or
on -current. Can you investigate further? (And what are you building

It was on i386. I'll try amd64 on my office machine (Core 2 duo). Besides, it was only a minor annoyance (easily fixed). The major problem after the build is this:

PM : amaya
21:25:41: Deleted stale lock file '/usr/vincent/.amaya_bin-vincent'.
[1]   Segmentation fault (core dumped) env XLIB_SKIP_AR...

and gdb gives me this :

Core was generated by `amaya_bin'.
Program terminated with signal 11, Segmentation fault.
#0  0xbb1b0566 in __fgetwc_unlock () from /usr/lib/
(gdb) bt
#0  0xbb1b0566 in __fgetwc_unlock () from /usr/lib/
#1  0xbb1aa71f in __vfwscanf_unlocked () from /usr/lib/
#2  0xbb1aa2e7 in vswscanf () from /usr/lib/
#3  0x08500ad3 in wxSscanf ()
#4  0x0831aefb in wxXmlResource::UpdateResources ()
#5  0x0831f15c in wxXmlResource::Load ()
#6  0x0821f486 in AmayaApp::OnInit ()
#7  0x08220ac5 in wxAppConsole::CallOnInit ()
#8  0x084d2550 in wxEntry ()
#9  0x0821e956 in main ()

Besides, I've worked on Amaya 10 this summer: I placed both wxGTK28 and Amaya10 in private repertories in my pkgsrc/wip tree. wxGTK28 compiled fine, Amaya10 also (maybe I fell on the same error, I don't remember), but, in the end, I got the same core dump related to wxSscanf, so this bugs happens whether you build the "embedded" wxGTK or you build against external wx-libraries.


Home | Main Index | Thread Index | Old Index