pkgsrc-Bulk archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkgsrc 2012Q1 NetBSD 6.0_BETA2/powerpc bulk build results 20120531.2159

>  > x11/py-gtk2                151
> It looks as if the old bulk build logic is not handling multiversion
> Python or Ruby packages right any more. (It also appears to be wasting
> a lot of build time recompiling wrong versions of the Python ones.)
> Maybe also php packages; not sure about phraseanet.
> Change to pbulk?

You know, it would be really nice if the procedure for setting up
pbulk in a chroot was documented in the fashion of

so that one could simply cut+paste the essential commands.
Alas, I find the documentation available at

to be woefully inadequate.  The latter can perhaps in comparison
best be described as "handwaving".  If I understand things
correctly, doing as described there will also mess with the
packages you already have installed in /usr/pkgsrc.  It seems to
me that a warning similar to the one in sectin 7.3.3 would be
highly appropriate, and that a separate section for setting up
pbulk in a chroot would be a good addition.

These days I simply don't have the time to deal with such under-
documented pieces of pkgsrc infrastructure software.

Quite a while ago I made an attempt at using pbulk, but I also
found it to be unhelpful if not directly hostile to a pkgsrc
bulk-build operator.  Case in point: it would sit there for a
couple of days computing dependencies (this was not on a modern
i386 or amd64 host), just to error out over what I seem to recall
to be a minor inconsistency in one or a few packages (in the
dependencies?), forcing a return to square zero, thereby both
wasting the long time it took to compute the dependencies, but
also insisting on my attention to proceed, and it was even not
obvious how to do so.  In my role as bulk build operator I found
it most inconvenient to be forced into the role of pkgsrc
developer to deal with the problem.  Insisting that each and
every package in the entire pkgsrc tree Must Be OK in order to
proceed with the rest is seriously decreasing the chance that
there will be forthcoming any result from the build effort, and I
just gave up on pbulk in utter frustration.

I'll admit that I've not tried to use pbulk lately, so some of
this may have changed for the better, but I find that the
documentation is still sorely lacking.

There, I feel a bit better now...

>  > devel/scmgit-docs          5
> => Checking for portability problems in extracted files
> [1]   Terminated              env CK_FNAME="${...
> *** Error code 1
> ?

That was me killing a runaway awk.  It looks like there's some
serious bug going around related to the awk pkgsrc uses, I
*think* it's the in-tree version.  I beleive this was doing the
"check for non-portable Bourne shell script constructs" thing in
pkgsrc, and awk just keeps on spinning on the CPU.  An attemt at
ktracing it resulted in a crash and PR#46591.  This of course
forced a restart of the bulk build -- how's that done with pbulk,
BTW?  It would be good to know for a bulk build operator -- for
the old it's just "do-bulk-build -r" ("-r" for "restart").

Looking at the console log, there's a lot of other incidents with
awk of these types:

trap: pid 29666.1 (awk): user write DSI trap @ 0x7f642010 by 0xfdec4cb8 (DSISR 
0x42000000, err=12)
UVM: pid 29666.1 (awk), uid 0 killed: out of swap
trap: pid 22081.1 (awk): user write DSI trap @ 0x651e5010 by 0xfdec4cb8 (DSISR 
0x42000000, err=12)
UVM: pid 22081.1 (awk), uid 0 killed: out of swap
trap: pid 19316.1 (awk): user read DSI trap @ 0xbc3048d0 by 0x1807788 (DSISR 
0x40000000, err=14)

Do we have regression tests for awk?  I tried
"cd /usr/src/tests/util/awk; make test", and it passed the few it
had there, but also said "make test is unsupported".

>  > graphics/fly             
> cd /usr/pkgsrc/graphics/fly/work/fly-1.6.5/doc; /usr/pkg/bin/gif2png *.gif
> gif2png: error in reading DataBlock
> gif2png: EOF / read error on image data
> Build host problem?

Don't know, could be.  It'll take a while for me to check,
though; I need to upgrade the "native" pkgsrc install first.

>  > lang/racket-textual      
> configure: error: "libffi has not been ported to powerpc--netbsd."

I'm pretty sure I did port devel/libffi to powerpc a while ago.
But maybe the configure script in this package has its own ideas
about that(?)

>  > print/lilypond             1

I run my bulk builds single-threaded (I have only one CPU on my
build host, a Mac Mini PPC).


- Håvard

Home | Main Index | Thread Index | Old Index