pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/55759: pkgsrc on Cygwin: sed error on bootstrap

>Number:         55759
>Category:       pkg
>Synopsis:       pkgsrc on Cygwin: sed error on bootstrap
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Tue Oct 27 20:05:00 +0000 2020
>Originator:     Evans Winner
>Release:        Not sure. cvs pkgsrc from a few days ago. I believe it was cvs checkout pkgsrc
CYGWIN_NT-10.0 gocl437 3.1.7(0.340/5/3) 2020-08-22 17:48 x86_64 Cygwin
Hi -- I am trying to see if I can get pkgsrc working on
Cygwin. I am not that familiar with pkgsrc, mainly because
it usually Just Works for me on Netbsd, and so I've never
had to dig into it much. I was excited to see it (might)
work on Cygwin, so I tried. I will copy the last few lines
of the results of the boostrap script below. I did ./cleanup
first and then ran ./bootstrap --unprivileged

I also will give the contents of $path under that. I tried
downloading a fresh copy of Cygwin's installer and then
updated all the packages it wanted to update first. I have
been using this install for a while, and so it's hard to
tell what might be old or that I might have messed up in
some way by now.

Looking at it, I suspect maybe the group name isn't expected
to have spaces in it, so it might be a quoting issue. But I
don't know how to figure out what script is running and
calling sed. Anyway, if anyone has any pointers for what I
should look at I would be grateful.


gcc -DHAVE_CONFIG_H -I/cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/libnbcompat -I/cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/libarchive/libarchive -I. -I. -I../lib -DBOOTSTRAP -g -O2 -c show.c
gcc -L/cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/libnbcompat -L../lib -o pkg_info main.o perform.o show.o -linstall  -lnbcompat
===> running: /usr/bin/sh /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/bin/install-sh -c -o 1060303 -g 1049089 -m 755 /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/pkg_install/add/pkg_add /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/sbin/pkg_add
===> running: /usr/bin/sh /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/bin/install-sh -c -o 1060303 -g 1049089 -m 755 /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/pkg_install/admin/pkg_admin /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/sbin/pkg_admin
===> running: /usr/bin/sh /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/bin/install-sh -c -o 1060303 -g 1049089 -m 755 /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/pkg_install/create/pkg_create /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/sbin/pkg_create
===> running: /usr/bin/sh /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/bin/install-sh -c -o 1060303 -g 1049089 -m 755 /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/pkg_install/info/pkg_info /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/sbin/pkg_info
===> Installing packages
===> running: (cd /cygdrive/c/Users/ewinner/s/pkgsrc/pkgtools/bootstrap-mk-files && /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/bin/bmake  MAKE_JOBS=1 PKG_COMPRESSION=none -DPKG_PRESERVE PKGSRC_KEEP_BIN_PKGS=no MAKECONF=/cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/mk.conf install)
===> Installing dependencies for bootstrap-mk-files-20180901
===> Overriding tools for bootstrap-mk-files-20180901
===> Extracting for bootstrap-mk-files-20180901
===> Patching for bootstrap-mk-files-20180901
===> Creating toolchain wrappers for bootstrap-mk-files-20180901
===> Configuring for bootstrap-mk-files-20180901
cd /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/wrk/pkgtools/bootstrap-mk-files/work/bootstrap-mk-files-20180901; for file in bsd.*; do                      test ! -f mods/Cygwin.$file ||                         /bin/cp -f mods/Cygwin.$file /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/wrk/pkgtools/bootstrap-mk-files/work/bootstrap-mk-files-20180901/$file;        done
cd /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/wrk/pkgtools/bootstrap-mk-files/work/bootstrap-mk-files-20180901;                                                   if test -f mods/; then                     own_mk=mods/;                       else                                                            own_mk=mods/;    fi;                                                              /cygdrive/c/Users/ewinner/s/pkgsrc/bootstrap/work/bin/sed      -e 's|@ROOT_GROUP@|'Domain Users'|g'                     -e 's|@ROOT_USER@|'ewinner'|g'                         -e 's|@SYSCONFDIR@|'/cygdrive/c/Users/ewinner/pkg/etc'|g'               $own_mk >
sed: 1: "s|@ROOT_GROUP@|Domain": unterminated substitute in regular expression
*** Error code 1

bmake[1]: stopped in /cygdrive/c/Users/ewinner/s/pkgsrc/pkgtools/bootstrap-mk-files
*** Error code 1

bmake: stopped in /cygdrive/c/Users/ewinner/s/pkgsrc/pkgtools/bootstrap-mk-files
===> exited with status 1


$ echo $path
/cygdrive/c/Users/ewinner/p /cygdrive/c/Users/ewinner/go/bin /cygdrive/c/emacs/x86_64/bin /cygdrive/c/Users/ewinner/.emacs.d/bin /cygdrive/c/Users/ewinner/.local/bin /cygdrive/c/Users/ewinner/.cargo/bin /usr/bin/mh /usr/local/sbin /usr/local/bin /usr/pkg/bin /usr/pkg/sbin /usr/sbin /usr/bin /sbin /bin

On Cygwin recently updated with Cygwin setup 2.905

pkgsrc in ~/s/pkgsrc from cvs.

$ cd ~/s/pkgsrc/bootstrap
$ ./cleanuup
$ ./bootstrap --unprivileged


Home | Main Index | Thread Index | Old Index