pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/54639: textproc/xmltooling fails to compile

>Number:         54639
>Category:       pkg
>Synopsis:       textproc/xmltooling fails to compile
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Oct 22 13:05:00 +0000 2019
>Originator:     Joern Clausen
>Release:        NetBSD 8.1/amd64
Bielefeld University
Compiling textproc/xmltooling on NetBSD 8.1/amd64 fails with this error:

XMLToolingConfig.cpp: In function 'TXFMBase* {anonymous}::TXFMOutputLogFactory(xercesc_3_2::DOMDocument*)':
XMLToolingConfig.cpp:182:41: error: invalid new-expression of abstract class type '{anonymous}::TXFMOutputLog'
             return new TXFMOutputLog(doc);
XMLToolingConfig.cpp:132:11: note:   because the following virtual functions are pure within '{anonymous}::TXFMOutputLog':
     class TXFMOutputLog : public TXFMBase {

I have not the slightest idea what this means...

FWIW: Compiling the package with lang/gcc8 on NetBSD or GCC 9.2.0 on Solaris throws exactly the same error. Upgrading to xmltooling-1.6.4 yields the same result. I remember successfully building version 1.5.3 two years ago, but this version fails now in the same way. I guess this error is related to boost, which was probably at a different version when I was able to compile this package the last time.


Home | Main Index | Thread Index | Old Index