pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/53771: digest keccak.c does not compile on IRIX with mipspro compiler

Any luck running the self-tests?

On Mon, 10 Dec 2018 at 13:01, Alistair Crooks <> wrote:
Can you try to run the self tests, please? (They're for SHA3, so quote relevant): "digest -t"


On Sun, 9 Dec 2018 at 22:57, <> wrote:
>Number:         53771
>Category:       pkg
>Synopsis:       digest keccak.c does not compile on IRIX with mipspro compiler
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Dec 10 06:45:00 +0000 2018
>Originator:     Erno Palonheimo
>Release:        current-20181201
IRIX64 arpakuutio 6.5 07202013 IP30 mips

keccak.c of digest package has this preprocessor macro:

#define FOR5(X, STMT) do                                                      \
{                                                                             \
        (X) = 0; (STMT);                                                      \
        (X) = 1; (STMT);                                                      \
        (X) = 2; (STMT);                                                      \
        (X) = 3; (STMT);                                                      \
        (X) = 4; (STMT);                                                      \
} while (0)

It results in code that has a gcc-specific syntax and Mipspro won't compile it.
Try to build digest on IRIX using Mipspro.
Discussion on Freenode #pkgsrc revealed that this could possibly be worked around by changing the (STMT) on the macro to {STMT} as suggested by Rhialto. I changed the file manually and at least the compiler compiled it and the digest command works now. If further help in testing this on IRIX is needed, I can run tests on the machine.

Home | Main Index | Thread Index | Old Index