pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/53258: MesaLib does not build on NetBSD-8.0_RC1 with nouveau

>Number:         53258
>Category:       pkg
>Synopsis:       MesaLib does not build on NetBSD-8.0_RC1 with nouveau
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu May 03 16:05:00 +0000 2018
>Originator:     Jake Slazenger
>Release:        NetBSD-8.0_RC1, pkgsrc-current-20180502
NetBSD localhost 8.0_RC1 NetBSD 8.0_RC1 (RUSTY) #0: Mon Apr 30 10:08:34 MSK 2018  rusty@localhost:/usr/src/src-8.0_RC1/sys/arch/amd64/compile/RUSTY amd64
Build of this package crashing and requiring 'dri3proto' package. 

So I've disabled dri3 option. 

After this change build crashing, but with new error that requires 'libdrm' package. So, I've installed this package and added some libdrm-specific variables to the Makefile for the configure phase.

Build crashing, but with new error:

gmake[5]: Entering directory '/usr/pkgsrc/pkgsrc-current/graphics/MesaLib/work/mesa-11.2.2/src/mesa/drivers/dri/i965'
  CC       brw_binding_tables.lo
In file included from brw_binding_tables.c:42:0:
brw_context.h:41:23: fatal error: intel_aub.h: No such file or directory
compilation terminated.
Makefile:1506: recipe for target 'brw_binding_tables.lo' failed
gmake[5]: *** [brw_binding_tables.lo] Error 1

How I can fix that? I tried to add INTEL_CFLAGS to CFLAGS variable, tried some other things, but it didn't give me any result.

Help me. Please.

Here is all changes that I've added to the package:

--- Makefile.old	2018-05-02 14:41:20.991950472 +0000
+++ Makefile
@@ -68,6 +68,28 @@ CFLAGS.SunOS+=	-D__EXTENSIONS__
 CONFIGURE_ARGS+=	--enable-glx-read-only-text
+# Configure-phase variables for libdrm_nouveau
+			                -I${PREFIX}/include/libdrm \
+			                -I${PREFIX}/include/libdrm/nouveau" 
+CONFIGURE_ENV+=		NVVIEUX_LIBS="-L${PREFIX}/lib -ldrm_nouveau"
+			                -I${PREFIX}/include/libdrm \
+			                -I${PREFIX}/include/libdrm/nouveau" 
+CONFIGURE_ENV+=		NOUVEAU_LIBS="-L${PREFIX}/lib -ldrm_nouveau"
+# Configure-phase variables for libdrm_amdgpu
+			               -I${PREFIX}/include/libdrm"
+CONFIGURE_ENV+=		AMDGPU_LIBS="-L${PREFIX}/lib -ldrm_amdgpu"
+# Configure-phase variables for libdrm_intel
+			              -I${PREFIX}/include/libdrm"
+CONFIGURE_ENV+=		INTEL_LIBS="-L${PREFIX}/lib -ldrm_intel"
+CFLAGS+=		-I${PREFIX}/include 
+CFLAGS+=		-I${PREFIX}/include/libdrm
 .if !empty(PKGSRC_COMPILER:Mclang)
 SUBST_STAGE.tr1=	pre-configure
@@ -112,6 +134,8 @@ INSTALLATION_DIRS+=	share/examples/MesaL
 	${INSTALL_DATA} ${WRKSRC}/src/mesa/drivers/dri/common/drirc ${DESTDIR}${PREFIX}/share/examples/MesaLib
+.include "../../x11/libdrm/"
 .include "../../x11/libX11/"
 .include "../../x11/libXext/"
 .include "../../x11/libxcb/"
---	2018-05-02 14:19:47.457960459 +0000
@@ -33,12 +33,17 @@ PLIST_VARS+=	gbm vaapi vdpau wayland xat
 CONFIGURE_ARGS+=	--enable-dri
 CONFIGURE_ARGS+=	--enable-egl
-.if ${OPSYS} != "Darwin"
+.if ${OPSYS} != "Darwin" || ${OPSYS} != "NetBSD"
 CONFIGURE_ARGS+=	--enable-dri3
 CONFIGURE_ARGS+=	--enable-gbm
 PLIST.gbm=		yes
+.if ${OPSYS} == "NetBSD"
+CONFIGURE_ARGS+=	--disable-dri3
 CONFIGURE_ARGS+=	--enable-gles1
 CONFIGURE_ARGS+=	--enable-gles2


Home | Main Index | Thread Index | Old Index