pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/49179: emacs taken from pkgin does a core dump when you try to run it

>Number:         49179
>Category:       pkg
>Synopsis:       emacs taken from pkgin does a core dump when you try to run it
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Sep 07 08:45:00 +0000 2014
>Originator:     Santhosh Raju
>Release:        NetBSD 6.1
NetBSD theta 6.1 NetBSD 6.1 (GENERIC) i386

I tried to install "emacs" from the pkgin package manager, there were no errors 
or issues during the install process, but once the install is done whenever I 
tried to run "emacs" it shows a "core dump" message.

theta# emacs
Memory fault (core dumped)

I also tried to start emacs with -nw option which also did not help.

I tried this with various packages available from pkgin ranging from 24.3 to 
20.7, I also tried installing the dev version of the package which did not help 
and the nox11 versions did not help as well.

In the end I downloaded emacs from and compiled 
it manually (version 24.3) and this one seemed to work without any issues. 
However during ./configure, I had to disable options with libjpeg, libpng, 
libgif and libtiff since those were missing in my fresh install of NetBSD.

P.S: I am running NetBSD in a VirtualBox instance
1. Install a fresh copy of NetBSD 6.1 in VirtualBox
2. Install emacs using pkgin
3. Try running emacs from command line
I do not know at this point.

Home | Main Index | Thread Index | Old Index