pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

RE: pkg/46754: Eclipse does not start

The following reply was made to PR pkg/46754; it has been noted by GNATS.

From: Germain Le Chapelain <>
To: <>
Subject: RE: pkg/46754: Eclipse does not start
Date: Fri, 4 Jan 2013 10:07:48 -0500

 >   > /usr/pkg/eclipse/eclipse=20
 >   > bash: /usr/pkg/eclipse/eclipse: No such file or directory
 > =20
 >  Is it a "real" binary (that is=2C one compiled for NetBSD) or a Java
 >  binary? If the latter=2C try running "java" on it.
 Thanks a great deal for the pointers !
 It's a Linux :
 bash-4.2$ file ./eclipse=20
 ./eclipse: ELF 32-bit LSB executable=2C Intel 80386=2C version 1 (SYSV)=2C =
 dynamically linked (uses shared libs)=2C for GNU/Linux 2.2.5=2C not strippe=
 So=2C installing
 =A0=A0=A0 emulators/suse121_32_compat
 =A0=A0=A0 emulators/suse121_32_x11
 made it pass the initial error and another `eclipse: error while loading sh=
 ared libraries: cannot open shared object file: No such file or=
 I am now getting a window error: `No Java virtual machine found'.
 I tried
 eclipse -vm /usr/pkg/java/sun-6/bin/java
 and I get=20
 BootLoader constants: OS=3Dlinux=2C ARCH=3Dx86=2C WS=3Dmotif=2C NL=3Den_US
 !ENTRY org.eclipse.osgi Jan 04=2C 2013 07:49:39.714
 !MESSAGE Application error
 java.lang.UnsatisfiedLinkError: /usr/pkg/eclipse/plugins/
 .0.1/os/linux/x86/ /usr/pkg/eclipse/plugins/org.eclips=
 .motif_3.0.1/os/linux/x86/ wrong ELF class: ELFCLASS32=
 sible cause: architecture word width mismatch)
 =A0=A0=A0=A0=A0=A0=A0 at java.lang.ClassLoader$NativeLibrary.load(Native Me=
 logged in ~/.eclipse/1357285779231.log=20
 I also tried
 eclipse -vm /usr/pkg/java/sun-6/bin/java_vm=20
 and I got:
 java_vm process: You need to set both JAVA_HOME and PLUGIN_HOME
 then :
 java_vm process: could not find Java VM symbols
 when I tried filling=20
 export JAVA_HOME=3D/usr/pkg/java/sun-6/
 export PLUGIN_HOME=3D/usr/pkg/java/sun-6/plugin/
 Germain Le Chapelain

Home | Main Index | Thread Index | Old Index