pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/46565: emulators/qemu (qemu-1.1.0) dumps core on NetBSD-5.1_STABLE/i386

>Number:         46565
>Category:       pkg
>Synopsis:       emulators/qemu (qemu-1.1.0) dumps core on 
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Jun 08 16:50:01 +0000 2012
>Originator:     John D. Baker
>Release:        NetBSD-5.1_STABLE/i386, pkgsrc-2012Q1 (w/some updated to -HEAD)
NetBSD slate.technoskunk.fur 5.1_STABLE NetBSD 5.1_STABLE (SLATE) #2: Sun Jun  
3 21:44:59 CDT 2012  

Following the update of emulators/qemu to 1.1.0 (shadowing wip/qemu),
I updated that package to -HEAD in my pkgsrc tree (is otherwise -2012Q1)
and built.

Attempting to run:

  $ qemu-system-i386 -cdrom /d0/build/netbsd-5/REL/iso/i386cd.iso wd0

Resulted in:

  Memory fault (core dumped)

Loading everything into gdb reveals:

Core was generated by `qemu-system-i386'.
Program terminated with signal 11, Segmentation fault.
#0  0xbba898dc in pthread_curcpu_np () from /usr/lib/
(gdb) bt
#0  0xbba898dc in pthread_curcpu_np () from /usr/lib/
#1  0xbb8f7478 in posix_memalign () from /usr/lib/
#2  0xbb8f7a83 in malloc () from /usr/lib/
#3  0xbbb56e29 in g_mem_set_vtable () from /usr/pkg/lib/
#4  0xbbb57242 in g_malloc0 () from /usr/pkg/lib/
#5  0x080945ce in ?? ()
#6  0x00000054 in ?? ()
#7  0x00000000 in ?? ()

The same result is had from 'qemu-system-sparc'.  I haven't tried any
other targets.
Update emulators/qemu to -HEAD.  Build and install on
NetBSD-5.1_STABLE/i386 (other host arches? other sub-branches of

(Was last observed to build and run fine on NetBSD-6.0_BETA2/i386.)

Home | Main Index | Thread Index | Old Index