pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/45959: dbus-glib fails to build in chroot

---- Greg Oster <> wrote: 
> On Mon, 13 Feb 2012 11:06:06 -0500
> <> wrote:
> > I also have the problem with dbus-glib (and others) not building on
> > NetBSD-5.1.1 (and 5.1.2) for amd64.  For what it's worth, it appears
> > to build successfully with the 2011Q4 sources, not -current and it
> > seems to be related to the recent changes to GLIB2.  The current
> > version of GLIB2 doesn't install or deinstall cleanly and many
> > packages built against it dump core.
> Thanks for this.. I tried playing a bit more, and in that process I
> removed the glib2-230.2nb1.tgz... when I tried to do a pkg_add to add
> it back, I got:
>   pkg_add packages/All/glib2-2.30.2nb1.tgz
>   [1]   Segmentation fault      "${GIO_QUERYMODU...
>   No schema files found: doing nothing.
> which I'm guessing is similar to what you've seen...
> Later...
> Greg Oster

Yes.  I'm also seeing this in other packages that are built against 
glib2.30.2nb1. Also comes up when trying to rebuild some packages with this 
version of glib2 installed both in my running system and inside a chroot with 
pkg_comp.  Don't see the problem building the same set of packages from the 
2011Q4 sources though, but there are source changes in -current beyond what is 
in 2011Q4.


Home | Main Index | Thread Index | Old Index