pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/45284: native Kerberos on Solaris (again)

>Number:         45284
>Category:       pkg
>Synopsis:       native Kerberos on Solaris (again)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Aug 23 13:50:00 +0000 2011
>Originator:     Jörn Clausen
University of Bielefeld
At the moment, the native Kerberos implementation of Solaris is not recognized 
as replacement for security/mit-krb5. Please see some of the remarks in 
pkg/44597 for reference.


---       2011/08/23 13:32:05     1.1
+++       2011/08/23 13:32:18
@@ -5,8 +5,8 @@
 .if !defined(MIT_KRB5_BUILDLINK3_MK)
 MIT_KRB5_BUILDLINK3_MK:=       mit-krb5>=1.8       mit-krb5>=1.8      mit-krb5>=1.8      mit-krb5>=1.8         ../../security/mit-krb5

Why is this defined in mit-krb5??? Shouldn't this be defined in the package 
including mit-krb5? So if >=1.8 is requested, the pkgsrc version is used, but 
without this constraint, the native version (on Solaris it is 1.4) can be used?

Home | Main Index | Thread Index | Old Index