pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/44786: pkgsrc 2010Q4 samba35 "somtimes" build with samba4 support

The following reply was made to PR pkg/44786; it has been noted by GNATS.

From: Wolfgang Stukenbrock <>
Subject: Re: pkg/44786: pkgsrc 2010Q4 samba35 "somtimes" build with samba4 
Date: Thu, 31 Mar 2011 11:06:21 +0200

 sorry no.
 After I run into problems with libintl on Solaris 2.8 build (problem 
 "solved" yesterday, but PR for that still not generated), I've debugged 
 configure and found that if python is available and the 
 --enable-merged-build is not given on the command line, configure may 
 select the merged build mode (default setting is "auto").
 For this decision it also checks for some additional other things like 
 "ads" is enabled and the make program is a GNU make.
 I tried to build it in merged mode.
 But on my Solaris 2.8 the build of libffi fails (required for python 
 build) so I stop testing this here - I don't want samba4 support ...
 Now I've checked it again on a NetBSD 5.0.2 system.
 If auto-selection is enabled and phyton is present, the auto detection 
 will fail due to a missing "Phyton.h" header file for the module test 
 and merged-mode gets disabled. That seems to be the reason why this 
 "problem" is not detected by someone else up to now.
 But "Phyton.h" is available in /usr/pkg/include/python2.6/Python.h and 
 the command line reported by configure for the compilation works fine if 
 called by hand:
   cc -o conftest -I/usr/include/krb5  -O2 -I/usr/include/krb5 
 -I/usr/include -I/usr/pkg/include -DLDAP_DEPRECATED 
 -I/usr/pkg/include/python2.6 -I/usr/pkg/include/python2.6 
 -I/usr/include/krb5  -I/usr/pkg/include -I/usr/pkg/include 
 -I/usr/include/krb5 -I/usr/include -I/usr/pkg/include -DLDAP_DEPRECATED 
 -Iinclude -I./include  -I. -I. -I./../lib/replace -I./../lib/tevent 
 -I./libaddns -I./librpc -I./.. -I./../lib/popt -I/usr/include 
 -DLDAP_DEPRECATED  -Wl,-z,ignore -L/usr/lib -Wl,-R/usr/lib 
 -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L./bin -L/usr/lib conftest.c -lresolv 
   -lresolv     -lpthread -lutil -lm -lpython2.6
 OK the modifications by the pkgsrc-wrapper stuff is not done if called 
 by hand.
 Error message in config.log:
 conftest.c:599:24: error: Python.h: No such file or directory
 conftest.c: In function 'main':
 conftest.c:605: error: 'NULL' undeclared (first use in this function)
 conftest.c:605: error: (Each undeclared identifier is reported only once
 conftest.c:605: error: for each function it appears in.)
 Source file generated is the following:
 /* confdefs.h.  */
 #define PACKAGE_NAME "Samba"
 #define PACKAGE_TARNAME "samba"
 #define PACKAGE_VERSION "3"
 #define PACKAGE_STRING "Samba 3"
 ..... lots of other defines ......
 /* end confdefs.h.  */
                                  #undef HAVE_UINTPTR_T
                                /* we have our own configure tests */
                                #include <Python.h>
 main ()
                                Py_InitModule(NULL, NULL);
    return 0;
 remark: the test programm will still not run if compiled by hand:
 "Fatal Python error: Interpreter not initialized (version mismatch?)"
 followed by a core dump, but as far as I understand the configure script 
 only the compilation and linkage is tested. The reason why compilation 
 failed if compiled in the pkgsrc-build is not known to me till now.
 Back to my "samba4" options ...
 If I set the enable option on the configure command line, the build 
 may/will fail for multible reasons:
 - ads is not enabled - need to be checked in - no usable 
 error indication from configure
 - a missing "#include <limits.h>" in source4/heimdal/lib/roken/base64.c
 - "some" missing RCSID definitions for several source files - may be a 
 missing include for a heimdal-config.h file - there RCSID is defined
 - during compilation "include/config.h" is not found
 ... here I stop analyses - there seems to a lot of work to get it 
 compiling ....
 OK - sorry again - I missed to check if it would ever compile and it 
 The source4 tree is not setup correctly during configure phase.
 I cannot say if the reason for this is a broken source in the samba tar 
 file or if it is related to the pkgsrc "patches" etc..
 I think, it would be better to disable merged build in all cases in samba35.
 This will speed up the configure script by bypassing lots of checks and 
 that part of the source will not compile at all (in pkgsrc-setup).
 I recommend to change my patch to the following:
 simply add --enable-merged-build=no to the configure options in 
 lang/samba35/Makefile and do not change lang/samba/ as 
 mentioned in my previous mails.
 sorry again - but I was in a hurry to get samba35 up and running on 
 Solaris 2.8, so I bypass a check of all setup varaints prior sending the PR.
 best regards
 W. Stukenbrock
 Takahiro Kambe wrote:
 > The following reply was made to PR pkg/44786; it has been noted by GNATS.
 > From: Takahiro Kambe <>
 > To:, 
 > Cc: 
 > Subject: Re: pkg/44786: pkgsrc 2010Q4 samba35 "somtimes" build with samba4
 >  support
 > Date: Thu, 31 Mar 2011 02:11:09 +0900 (JST)
 >  Hi,
 >  In message <>
 >      on Tue, 29 Mar 2011 10:30:00 +0000 (UTC),
 > wrote:
 >  >>Fix:
 >  >   The following patch to /usr/pkgsrc/net/samba/ will
 >  >   add a samba4 option for samba35 and disable it by default.
 >  Have you successfully build samba35 when samba4 PKG_OPTION is enable?
 >  -- 
 >  Takahiro Kambe <>/<>
 Dr. Nagler & Company GmbH
 Hauptstraße 9
 92253 Schnaittenbach
 Tel. +49 9622/71 97-42
 Fax +49 9622/71 97-50
 Hauptsitz: Schnaittenbach
 Handelregister: Amberg HRB
 Gerichtsstand: Amberg
 Steuernummer: 201/118/51825
 USt.-ID-Nummer: DE 273143997
 Geschäftsführer: Dr. Martin Nagler, Dr. Dr. Karl-Kuno Kunze

Home | Main Index | Thread Index | Old Index