pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/44066: emulators/e-uae crashes on amd64

>Number:         44066
>Category:       pkg
>Synopsis:       emulators/e-uae crashes on amd64
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Nov 08 08:55:00 +0000 2010
>Originator:     David A. Holland
>Release:        NetBSD 5.99.29 (20100529)
System: NetBSD valkyrie 5.99.29 NetBSD 5.99.29 (VALKYRIE) #1: Sat May 29 
23:00:44 EDT 2010  dholland@valkyrie:/usr/src/sys/arch/amd64/compile/VALKYRIE 
Architecture: x86_64
Machine: amd64

e-uae crashes during startup:

   valkyrie% uae
   E-UAE 0.8.28
   Build date: Nov  7 2010 01:41:48
   SDLGFX: Initialized.
   SDLGFX: Using SDL version 1.2.14.
   SDLGFX: Display is 32 bits deep.
   SDLGFX: Found screenmode: 1152x864.
   SDLGFX: Found screenmode: 1024x768.
   SDLGFX: Found screenmode: 832x624.
   SDLGFX: Found screenmode: 800x600.
   SDLGFX: Found screenmode: 720x400.
   SDLGFX: Found screenmode: 640x480.
   SDLGFX: Found screenmode: 640x400.
   SDLGFX: Found screenmode: 640x350.
   Found 0 joystick(s)
   Using cooked keymap
   Opening cfgfile '/disk/disk1/home/dholland/.uaerc'...failed
   Opening cfgfile '.uaerc'...failed
   Testing the RDTSC instruction ... done.
   Calibrating TSC frequency...TSC frequency: 3065.939070 MHz
   Testing system sleep function..
   Average duration of a 1ms sleep: 18 ms
   Enabling busy-waiting for sub-10ms sleeps
   Using cooked keymap
   Segmentation fault
   Exit 139

Appears to be gtk-related:

#0  0x00007f7ff7e288ce in g_type_is_a () from /usr/pkg/lib/
#1  0x00007f7ffd41c5ce in gtk_type_new () from /usr/pkg/lib/
#2  0x00000000004661e8 in ?? ()
#3  0x00007f7ff723b723 in g_source_get_current_time () from 
#4  0x00007f7ff723b049 in g_main_context_dispatch () from 
#5  0x00007f7ff723e3bf in g_main_context_prepare () from 
#6  0x00007f7ff723e6f9 in g_main_loop_run () from /usr/pkg/lib/
#7  0x00007f7ffd329fd1 in gtk_main () from /usr/pkg/lib/
#8  0x000000000045f908 in ?? ()
#9  0x00007f7ff6a11add in SDL_RunThread () from /usr/pkg/lib/
#10 0x00007f7ff6a4a74f in RunThread () from /usr/pkg/lib/
#11 0x00007f7ff660ad79 in pthread_setcancelstate () from 
#12 0x00007f7ff6272b50 in ___lwp_park50 () from /usr/lib/
#13 0x00007f7ff2400000 in ?? ()
#14 0x0000000111110001 in ?? ()
#15 0x0000000033330003 in ?? ()
#16 0x0000000000000000 in ?? ()

gtk2+ is 2.20.1nb2
glib2 is 2.26.0

Reverting the most recent glib2 update did not make the problem go
away. I haven't tried more elaborate reversions because I ran into
unrelated odd problems with make undo-replace.

I think this used to work months ago, but I'm not entirely sure if
that was e-uae or plain uae.


as above, just run it.


Dunno. As a workaround, compile without gtk support.

Home | Main Index | Thread Index | Old Index