pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42579: Undelivered Mail Returned to Sender

>Number:         42579
>Category:       pkg
>Synopsis:       Undelivered Mail Returned to Sender
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jan 05 02:40:00 +0000 2010
>Originator:     Sverre Froyen
>Release:        NetBSD 5.99.23
System: NetBSD 5.99.23 NetBSD 5.99.23 (ABBOR) #12: Thu Dec 31 
10:02:20 MST 2009 
Architecture: x86_64
Machine: amd64
At some point, possibly all the way back to when I first tried KDE4, I started 
to see crashes in plasma-desktop.  Because it restarts automatically, however, 
fixing it was not a priority, but I did start collecting backtraces from core 
dumps.  One of these shows a problem in the resolver library:

Core was generated by `plasma-desktop'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007f7ff56e18ba in _lwp_kill () from /usr/lib/
(gdb) bt
#0  0x00007f7ff56e18ba in _lwp_kill () from /usr/lib/
#1  0x00007f7ffaea4f15 in KCrash::defaultCrashHandler (sig=11) at 
#2  <signal handler called>
#3  0x00007f7ff5689bbb in _malloc_prefork () from /usr/lib/
#4  0x00007f7ff5689e13 in free () from /usr/lib/
#5  0x00007f7ff56a0f3d in __res_ndestroy () from /usr/lib/
#6  0x00007f7ff56a216f in __res_vinit () from /usr/lib/
#7  0x00007f7ff56a967b in res_init () from /usr/lib/
#8  0x00007f7ffb89e683 in QHostInfoAgent::fromName ()
Use the KDE4 desktop on NetBSD current.
According to Christos, res_init should not be used in a multithreaded program 
program (which this is).  I do not pretend to understand the Qt code, but
res_init is called from QHostInfoAgent::fromName if local_res_init is set.
Preventing this variable from being set makes the crashes stop (for me at
least).  Besides, setting local_res_init seems superfluous since NetBSD
has res_ninit - which is thread-safe.  The following patch (to x11/qt4-libs)
 has worked well for me:

--- src/network/kernel/qhostinfo_unix.cpp.orig  2009-12-22 08:24:04.000000000 
+++ src/network/kernel/qhostinfo_unix.cpp       2009-12-22 08:25:32.000000000 
@@ -115,6 +115,8 @@ static void resolveLibrary()
         if (!local_res_nclose)
             local_res_ninit = 0;
+    if (local_res_ninit)
+       local_res_init = 0;


 This is a MIME-encapsulated message.
 Content-Description: Notification
 Content-Type: text/plain; charset=us-ascii
 This is the mail system at host
 I'm sorry to have to inform you that your message could not
 be delivered to one or more recipients. It's attached below.
 For further assistance, please send mail to postmaster.
 If you do so, please include this problem report. You can
 delete your own text from the attached returned message.
                    The mail system
 <>: host[] said:
     554 5.7.1 <>: Relay access denied (in 
reply to
     RCPT TO command)
 Content-Description: Delivery report
 Content-Type: message/delivery-status
 Reporting-MTA: dns;
 X-Postfix-Queue-ID: AAD542742C
 X-Postfix-Sender: rfc822;
 Arrival-Date: Mon,  4 Jan 2010 12:36:22 -0700 (MST)
 Final-Recipient: rfc822;
 Action: failed
 Status: 5.7.1
 Remote-MTA: dns;
 Diagnostic-Code: smtp; 554 5.7.1 <>: 
Relay access
 Content-Description: Undelivered Message
 Content-Type: message/rfc822
 Return-Path: <>
 Received: by (Postfix, from userid 101)
        id AAD542742C; Mon,  4 Jan 2010 12:36:22 -0700 (MST)
 Subject: KDE4 plasma crashes - Qt4 resolver interface issue
 X-send-pr-version: 3.95
 Message-Id: <>
 Date: Mon,  4 Jan 2010 12:36:22 -0700 (MST)
 The KDE4 plasma desktop crashes randomly.

Home | Main Index | Thread Index | Old Index