pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/40457: Diffs for various minor pkgsrc-2008Q4 fixes

The following reply was made to PR pkg/40457; it has been noted by GNATS.

From: "OBATA Akio" <>
Subject: Re: pkg/40457: Diffs for various minor pkgsrc-2008Q4 fixes
Date: Sat, 24 Jan 2009 17:10:21 +0900

 Please not send tons of issues in one PR.
 It made hard to track individual issue.
 On Fri, 23 Jan 2009 16:25:00 +0900, <> wrote:
 > db4 failed to build in some C++ code when building the rarely used RPC
 > code.  This could potentially eventually be put as an option, but the
 > package was building it with --enable-rpc by default.
 What is the "db4 failed to build in some C++ code" ?
 It should be fixed instead.
 > NSPR required an older autoconf to build, and the Makefile already
 > was fixed to require said autoconf;  yet it still invoked the new
 > autoconf rather than the old one, which requires the version suffix.
 If "autoconf213" is in USE_TOOLS, "autoconf" shold be just a wrapper of 
 You can confirm it by "ls ${WRKDIR}/.tools/bin/autoconf".
 If it is not a symbolic link to "autoconf-1.13", it is the real issue.
 > I'm not sure of the proper variable or fix to use here, netbsd-5 was 
 > installed
 > with in-base xorg, and no X11 related options are in mk.conf.  It somehow
 > couldn't find the path to glut, which is part of base xorg.  This hack worked
 > for me yet is not a proper solution.
 It is not X11 related matter, just builtin v.s. pkgsrc.
 ${BUILDLINK_PREFIX.glut} should know the path to glut.
 > The following failed to build only because the bootstrap SBCL couldn't
 > be downloaded, as it didn't yet exist on the maintainer's site.
 > This fix isn't a proper solution, but since my kernel was built with
 > COMPAT_4 support I forced it to use an SBCL built for 4.0 as bootstrap.
 > I now have a working SBCL for 5.0 which may be used to bootstrap for 5.0,
 > if the maintainer is interested.
 Not only COMPAT_4, but also shared libraries for NetBSD-4, isn't it?
 > Interestingly bogofilter configure script complained that "a proper libdb"
 > couldn't be found.  Making it use db4 worked for me.
 > -CONFIGURE_ARGS+=            --with-database=db
 > +CONFIGURE_ARGS+=            --with-database=db4
 from "make configure-help":
   --with-database=ENGINE  choose database engine
                           {db|qdbm|sqlite3|tokyocabinet} [db]
 There is no option "db4".
 You should read ${WRKSRC}/config.log to find why failed on your environment.
 > This was also part of a now-closed PR, but it seems it never was applied.
 > It adds options to mplayer so that it doesn't fail to build when it detects
 > the existence of these libraries: speex and lzo.  Interestingly, it also
 > fails to build if ncurses is installed, unless built with the ncurses option,
 > because of conflicts with in-base curses (it detects ncurses and attempts
 > to use it yet wrongly without the buildlink include).
 What is the "now-closed PR" ?
 If it was closed without fixed all, comment to the PR and reopen instead.
 > Ghostscript fails to build when debugging is disabled, it appears to be
 > a ghostcript bug, at linking time it couldn't find some symbols only built
 > when debugging is enabled.  I thus simply re-enabled debugging which was
 > commented out, which made it build fine.
 What is the failure?
 I can't reproduce it.
 > Requires the ncurses buildlink include if ncurses exist on the system
 > (and a dependency of another package also requireing hunspell installs
 > ncurses).
 > Index: textproc/hunspell/Makefile
 > +.include "../../devel/ncurses/"
 It should already be included from "".
 > Another case using an older autoconf requireing the version prefix.
 > Index: www/firefox/Makefile.common
 > Yet another similar case but with older automake.
 > Index: www/libwww/Makefile
 Same as above.
 > Requires ncurses buildlink include or it fails to build if ncurses exists
 > (which generally installs via another dependency).
 > Index: x11/vte/Makefile
 > +.include "../../devel/ncurses/"
 I can't reproduce it.
 In configure, just check ncurses, curses, termcap, so should just include
 "Of course I love NetBSD":-)
 OBATA Akio /

Home | Main Index | Thread Index | Old Index