pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/37522: Diffs to update lang/squeak to 3.9

The following reply was made to PR pkg/37522; it has been noted by GNATS.

From: Brian de Alwis <>
To: Christoph Badura <>
Subject: Re: pkg/37522: Diffs to update lang/squeak to 3.9
Date: Sun, 13 Jan 2008 16:35:15 -0600

 Hi Chris.  My apologies to Obata-san for not replying -- I had to put  
 this on the back burner as I've switched jobs, operating systems, and  
 while trying to work on my dissertation.
 I should say that my "porting" was purely mechanical to report  
 whatever patches to the newer Squeak.
 > Can you answer Obata-san's question regarding the patch to platforms/ 
 > unix/vm/sqUnixCharConv.c (__sun__ vs. __sun)?
 As I replied to Obata-san, the change from __sparc to __sun__ was  
 actually a Squeak change, not mine.  I only updated it to add  
 __NetBSD__ again.
 > Also, why did you disable the OSS sound module?
 I don't believe my patches disabled the OSS sound module?
 My patches did cause a problem for the sqUnixSoundNetBSD.c module on  
 NetBSD 4.0.  This was a simple mistake due to my developing on NetBSD- 
 current at the time.  The previous version of Squeak had all audio- 
 related decls in a header called 'aio.h' and all audio-related things  
 included this header.  aio.h was renamed to sqaio.h in the current  
 version of Squeak.  NetBSD introduced an aio.h in -current during this  
 time.   The sqUnixSoundNetBSD.c is actually carried in pkgsrc (not  
 sure if it was ever sent upstream) and was written against the older  
 release of Squeak to use aio.h,  Not having known of the Squeak  
 rename, I (wrongly) assumed this was referencing the header in - 
 current in /usr/include/.
 Anyways, I have NetBSD 4.0 now running as a guest and tried building  
 lang/squeak.  There is a minor error in the install target, and I've  
 also addressed Obata-san's point to deal with npsqueak's requiring  
 bash (it does).
 Unfortunately I don't actually think the audio capabilities are  
 working.  I tried filing in AudioNotes, a simple recording app, from 
  > (the "AudioNotes add-on" link at the bottom of the page) and I get  
 a walkback.
 === modified file 'lang/squeak/Makefile'
 --- lang/squeak/Makefile       2008-01-13 20:52:02 +0000
 +++ lang/squeak/Makefile       2008-01-13 22:03:45 +0000
 @@ -21,6 +21,9 @@
   AUTOCONF_REQD=       2.57
   AUTOMAKE_REQD=       1.4.6
 +# bash required by platforms/unix/npsqueak/
 +DEPENDS+=     bash:../../shells/bash
   BUILD_DIRS=          ${WRKDIR}/build
   CONFIGURE_DIRS=              ${WRKDIR}/build
   CONFIGURE_SCRIPT=    ${WRKSRC}/platforms/unix/config/configure
 @@ -45,8 +48,8 @@
        cd ${DESTDIR}${PREFIX}/lib/squeak                               \
            && ${LN} -s ${SQUEAK_CHANGES:C/.*\///} squeak.changes.gz    \
   Brian de Alwis | Software Practices Lab | UBC |
        "Amusement to an observing mind is study." - Benjamin Disraeli

Home | Main Index | Thread Index | Old Index