pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/29606: Error from Perl/Tk on script which formerly worked on NetBSD 1.6.2

The following reply was made to PR pkg/29606; it has been noted by GNATS.

From: Klaus Heinz <>
Subject: Re: pkg/29606: Error from Perl/Tk on script which formerly worked on 
NetBSD 1.6.2
Date: Thu, 4 Oct 2007 01:03:10 +0200 wrote:
 > Download this Perl/Tk script from CPAN and put it anywhere.
 I have built a small package for this, available at
 >  ...and in particular with the routine below...
 >  # Accept drops from an external application
 >  $nb->DropSite(-dropcommand => \&handleDND,
 >                 -droptypes   => ($^O eq 'MSWin32' or ($^O eq 'cygwin' and
 >                                 $Tk::platform eq 'MSWin32')) ? ['Win32'] :
 >                                 [qw/KDE XDND Sun/]);
 >  ...which, if I take out the 'KDE' from above, then the script
 >  will load and run but behave badly. By behaving badly, I mean it will
 >  open files but display strange character-groups for every line break.
 >  So perhaps KDESite is part of the Tk module which was present in the
 >  older version and missing in the new? And, perhaps it is needful for
 >  the Tk::DropSite module to work on NetBSD? Just a guess...
 This is exactly the root of the problem. According to the file
 "Change.log" from p5-Tk:
   Change 3205 on 2004/03/17 by nick@llama
         Re-factor DragDrop:: Rect and SunDrop so latter works again
         while keeping the fix to local and XDND protocols.
         Remove KDEDrop and KDESite (a weak ad hoc protocol used by KDE 2).
 The files and are still part of p5-Tk but is not.
 The bad behaviour you write about probably refers to the character
 sequence "\x(d)". I see this as well if I open the file
 but I can avoid it by enabling the option "CR/LF conversion" from the
 "Misc" menu before loading the file. This is simply the way t-pad
 displays text files coming from Windows, ie with carriage return+linefeed
 as line separator.
 I could not test actual drag-and-drop behaviour, no KDE here.
 Since pkgsrc can do nothing about the vanished KDE support and the
 strange line breaks are not strange at all, I believe this PR could be

Home | Main Index | Thread Index | Old Index