NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

cannot start detached sessions (with -m -d) back to back

I have noticed some odd behavior by Gnu Screen.

This is what I see

-bash-5.1$ /usr/pkg/bin/screen -S some-session -p 0 -m -d
-bash-5.1$ screen -X quit
-bash-5.1$ /usr/pkg/bin/screen -S some-session -p 0 -m -d
-bash-5.1$ screen -X quit
 No screen session found.

After the second invocation no screen session is actually started. For the sake of a simple example I am just running screen -X quit but other commands such as screen -ls show no screen sessions and I am not able to attach to any sessions (since truly none exist). Screen version 4.08.00 (GNU) 05-Feb-20

There seems to be no error whatsoever, any ideas of what could be happening here?

I have tried the same thing on MacOS 11.6 (Big Sur) with Screen version 4.00.03 (FAU) 23-Oct-06 and do not have the same error. I have tried this on NetBSD amd 64 9.2 and NetBSD macppc 9.1 with the same result. This definitely seems to be NetBSD specific, at least with this version (4.08.0) from pkgsrc.

Any ideas of what is going on?

Home | Main Index | Thread Index | Old Index