NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Unable to join open WEP wireless network

On Fri, Feb 02, 2018 at 07:34:22AM -0700, Andy Ruhl wrote:
> I was reading this from the context of "oh you have to use the old WEP
> way" to connect to an open network using ifconfig. I remember doing
> this many years ago.
> I have no idea if stuff changed since then, but the ifconfig command
> still appears to support connecting to open networks and WEP
> networks... Just need to figure out what is happening in this case.

I visited a hotel recently that had an "open" wireless network, the
wireless had no auth itself but they redirected you to an authentication
portal the first time you connected after which things Just Worked(tm)
for the rest of our stay.  I did this to get connected:

/etc/rc.d/wpa_supplicant stop  (assuming you have that running)
ifconfig urtwn0 ssid "" down
dhclient urtwn0

Once I think I confused the wireless adaptor when messing around and I
had to unplug/plug it again (it is a usb adaptor so that was easy) but
most of the time it worked fine.

Brett Lymn
Let go, or be dragged - Zen proverb.

Home | Main Index | Thread Index | Old Index