NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

USB & PCI Audio Device Problems

I have several NetBSD hosts running 7.1 that I use as workstations. Sound has been a big pain. USB sound never works (anywhere under any circumstances on any device). Anything that tries to play sound to a USB audio device says "Audio device got stuck!". I would think it's related to the USB side of things, but I've seen that same error on PCI devices too. On one machine I've tried four (supposedly supported) PCI sound cards without any luck. Each one either locks up the machine during boot, or says "Audio device got stuck!" when attempting to play audio. However, each one also works fine in Windows on the same hardware (swapping drives and booting Windows 7 works fine and sound works). So, I have hard time believing it's a hardware issue.

However, machines with an HD audio controller (Intel) tend to work fine.

Since I'm having across the board failure with anything other than Intel sound, is there something I'm likely overlooking or doing wrong? I've done things like compile custom kernels with only *one* sound card supported but it doesn't help (nor does full a full debug kernel et al).

Any ideas on what to do? Here are the specific devices that fail:

USB (broken in amd64 and i386):
  - Plantronics USB Headset
  - Sound Blaster Play! v2 USB
  - Sound BlasterAxx v1
  - Various cheap Crystal Sound USB 1.x dongles

PCI Sound Cards:
  - Sound Blaster X-Fi Platinum PCI
  - ESS Maestro 3 PCI
  - Sound Blaster Live! PCI
  - Ensoniq AudioPCI

Anyone have one of those that works? Anyone have anything USB or PCI that works? My basic issue is that I've got two machines that won't produce sound out of anything besides the mobo onboard sound (Intel HD audio).


Home | Main Index | Thread Index | Old Index