[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Honey I hosed pkgsrc!
During an effort to build epiphany in pkgsrc (i386,
off-the-shelf netbsd 6.1.3) I ran out
of disk-space; pkgsrc partition was *much* too small.
So I switched the partitions holding /usr/pkgsrc and
/usr/local. The latter had plenty of room. I did a
fresh cvs of pkgsrc on the just-renamed (and of course
rebooted) partition and ran smack into this upon
trying again to build epiphany:
checking pkg-config is at least version 0.9.0... yes
checking for wayland-scanner... no
checking for WAYLAND_DEPENDENCIES... no
checking whether build environment is sane... yes
checking for BASE_DEPENDENCIES... no
configure: error: Package requirements (glib-2.0 >=
2.39.5 atk >= 2.7.5 pango >= 1.32.4 cairo >=
1.12.0 cairo-gobject >= 1.12.0 gdk-pixbuf-2.0 >=
2.27.1) were not met:
Requested 'glib-2.0 >= 2.39.5' but version of GLib is
Consider adjusting the PKG_CONFIG_PATH environment
variable if you installed software in a non-standard
To look at just the first of those errors, glib-2.0,
that is now in pkgsrc at version 2.4.0. So it
seems that package requirements are not being
correctly discerned; at least, the build of epiphany
did not stop to build the needed, newer, glib-2.0.
Is there a database I need to rebuild on account of
moving /usr/pkgsrc to a new partition?
"Natasha! First we shoot jet, then we go after moose and squirrel."
Main Index |
Thread Index |