NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: X11 makes black screen


On Fri, 02 Aug 2013 12:41:50 +0200, Dave Tyson <>

Hi Riccado,

I have an old Thinkpad 600 (identified as 2645-4A0) and put the latest
NetBSD-6 snapshot on it. It booted up fine and a startx (no xorg.conf
present) brought up the default X display with twm and three windows.
The BIOS is too old for NetBSD to use ACPI without it being forced with
acpi_force_load, but X works without this anyway. Dmesg attached is with
ACPI forced on.

mine is "just" a 2645. I don't see further codes on mine, but having a
Pentium-class CPU should make it a 600.

I have never head about a 600R

About ACPI I read that perhaps some needs an update to the BIOS to enable
it? I am not sure. it has ACPI in theory.

narsil# dmesg | grep acpi
acpi0 at mainbus0: Intel ACPICA 20110623
acpi0: X/RSDT: OemId <IBM   ,TP600   ,00000001>, AslId <    ,00000000>
acpi0: SCI interrupting at int 9

later it recognizes battery and other stuff.

I think there were quite a few variants of the 600 which had different
video adaptors, mine has a Neologic one which X detects as neo2200.
Dmesg and Xorg log attached. If you have an Intel graphics adaptor there
have been some issues with acceleration which are being worked on in a
SOC project - you could try X-configure and then edit the resulting and uncomment NoAccel and see if that make any difference.

I have a Neomagic, I'm almost sure, but I don't see anything in dmesg
proving it!

narsil# dmesg | grep vga
vga1 at pci0 dev 3 function 0: vendor 0x10c8 product 0x0004 (rev. 0x01)
wsdisplay0 at vga1 kbdmux 1: console (80x25, vt100 emulation), using wskbd0
drm at vga1 not configured

X -configure writes inside the xorg file:

          Driver      "neomagic"

The standard generated xorg generates the same mtrr error though. Perhaps
you get away because you already have a 686 class cpu?

I created the Xorg file, commented out ALL modules, still when I run it:

(++) Using config file: "/root/"
mtrr set failed: Function not implemented

When I chec the created log file, i see the card to be configured, thus it
is not a module. Look:

[   911.500] (==) NEOMAGIC(0): DPI set to (96, 96)
[   911.500] (II) Loading sub module "fb"
[   911.500] (II) LoadModule: "fb"
[   911.525] (II) Loading /usr/X11R7/lib/modules/
[   911.544] (II) Module fb: vendor="X.Org Foundation"
[   911.544]    compiled for 1.10.3, module version = 1.0.0
[   911.545]    ABI class: X.Org ANSI C Emulation, version 0.4
[   911.545] (II) Loading sub module "xaa"
[   911.546] (II) LoadModule: "xaa"
[   911.573] (II) Loading /usr/X11R7/lib/modules/
[   911.625] (II) Module xaa: vendor="X.Org Foundation"
[   911.625]    compiled for 1.10.3, module version = 1.2.1
[   911.626]    ABI class: X.Org Video Driver, version 10.0
[   911.626] (II) Loading sub module "ramdac"
[   911.627] (II) LoadModule: "ramdac"
[   911.627] (II) Module "ramdac" already built-in
[   911.639] (WW) NEOMAGIC(0): remove MTRR a0000 - b0000
[   911.776] (II) NEOMAGIC(0): Stretching disabled
[   912.244] (II) NEOMAGIC(0): Using linear framebuffer at: 0xD0000000
[   912.244] (--) NEOMAGIC(0): 1137152 bytes off-screen memory available
[   912.245] (II) NEOMAGIC(0): Using H/W Cursor.
[   912.265] (II) NEOMAGIC(0): Using 424 scanlines of offscreen memory
[   912.270] (II) NEOMAGIC(0): Using XFree86 Acceleration Architecture
[   912.270]    Screen to screen bit blits
[   912.271]    Solid filled rectangles
[   912.271]    Solid Horizontal and Vertical Lines
[   912.275]    Setting up tile and stipple cache:
[   912.275]            18 128x128 slots
[   912.290] (II) NEOMAGIC(0): Acceleration  Initialized
[   912.291] (==) NEOMAGIC(0): Backing store disabled
[   912.291] (==) NEOMAGIC(0): Silken mouse enabled
[   912.319] (==) NEOMAGIC(0): DPMS enabled
[   912.322] (==) RandR enabled
[   912.322] (II) Initializing built-in extension Generic Event Extension
[   912.323] (II) Initializing built-in extension SHAPE
[   912.323] (II) Initializing built-in extension MIT-SHM
[   912.324] (II) Initializing built-in extension XInputExtension
[   912.324] (II) Initializing built-in extension XTEST
[   912.325] (II) Initializing built-in extension BIG-REQUESTS
[   912.325] (II) Initializing built-in extension SYNC
[   912.326] (II) Initializing built-in extension XKEYBOARD
[   912.326] (II) Initializing built-in extension XC-MISC
[   912.327] (II) Initializing built-in extension SECURITY
[   912.327] (II) Initializing built-in extension XINERAMA
[   912.327] (II) Initializing built-in extension XFIXES
[   912.328] (II) Initializing built-in extension XFree86-Bigfont
[   912.328] (II) Initializing built-in extension RENDER
[   912.329] (II) Initializing built-in extension RANDR
[   912.329] (II) Initializing built-in extension COMPOSITE
[   912.330] (II) Initializing built-in extension DAMAGE
[   912.549] (II) AIGLX: Screen 0 is not DRI capable
[   913.044] (II) AIGLX: Loaded and initialized
[   913.045] (II) GLX: Initialized DRISWRAST GL provider for screen 0

I get a single WW line... the log file doesn't have a single error, yet I
get a big black screen

I'm puzzled.


Home | Main Index | Thread Index | Old Index