NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Network changes between 4.x and 5.1RC3 ?

Thanks for the replies. I have tried:

* turning off ipf

* turning off hardware checksum, I just did
"ifconfig bge1 -ip4csum -tcp4csum -udp4csum -tso4"

* few more sysctl settings, kern.sbmax kern.somaxkva net.inet.ip.ifq.maxlen

* Check SSL versions, try a couple of different versions.

Not entirely sure there has been any difference. Tried booting old kernel, but alas, "mount" is too new and won't talk to the older kernel. Without being about to mount anything, it isn't so useful :)

As for the large transfers that stall, I did notice that 200M transfers are fine, but 500M transfers are not. Tempted to try sizes and work out exactly what size it dies on..

I will keep poking anyway.

rudolf wrote:
Jorgen Lundman wrote:
Many large transfers look like this, in the last few packets:
and it pretty much sits there forever.

I have seen something loosely similar on an old OpenSolaris box with ipf
(here is the common denominator with NetBSD). Turning ipf off fixed the
stalls and eventually i figured that it must have been a bug in ipf
"state" handling code - when the rules were written without using the
"state", everything was going normal.


Jorgen Lundman       | <>
Unix Administrator   | +81 (0)3 -5456-2687 ext 1017 (work)
Shibuya-ku, Tokyo    | +81 (0)90-5578-8500          (cell)
Japan                | +81 (0)3 -3375-1767          (home)

Home | Main Index | Thread Index | Old Index