NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problem with gpt partitioning in NetBSD-5.0.2 amd64


I have created a RAID5 array called sd0 with the following size etc:

sd0 at scsibus0 target 0 lun 0: <Areca, Volume Set #0, R001> disk fixed
sd0: 4190 GB, 72660 cyl, 252 head, 480 sec, 512 bytes/sect x 8789061120

I have been able to create a gpt partition of the whole array, created a
wedge and format it with newfs. But now, after some experiments, I am
trying to do that again. But always fails at the creation of the gpt
table: it is too small.

# gpt destroy sd0                                                      
# gpt create sd0
# gpt show sd0
   start    size  index  contents
       0       1         PMBR
       1       1         Pri GPT header
       2      32         Pri GPT table
      34  204733        
  204767      32         Sec GPT table
  204799       1         Sec GPT header

I have tried to "erase" the disk with a couple of different dd commands.
But it seems that gpt says that my disk is equal the amount of zeros
that i write with the dd command. Zeroing a 4T disk will not be ver
fast. What am I doing wrong? How do I erase the disk so gpt can again
utilize my entire disk?

When it worked I use the following commands:

# gpt destroy sd0
# gpt create sd0
# gpt add -t ufs sd0
# dkctl sd0d addwedge dk0 34 8789061053 ffs
# newfs -O2 -s -64m rdk0


Home | Main Index | Thread Index | Old Index