NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

performance issues with 9.1 and 9.2 on Thinkpad X250 and T550


I just wanted to report a few issues I've encountered with both NetBSD 9.1 and 9.2, mainly running on a Lenovo Thinkpad X250 but tested on a T550 and under Qemu-kvm as well. This will be a first message in a series. I'm reporting these issues in the hopes they can contribute to the project and in the interest of new users.

Both the X250 and the T550 come with an Intel i5 processor. The X250 has 8Gb of RAM. The T550 has 16Gb of RAM at its disposal. Both have an internal SSD with a capacity of about 500Gb. Each time I set up an unencrypted root partition and a encrypted home + swap partitions (cgd aes-x512), with both taking up about 85% of the total disk size.

Here is a brief overview:

* RAM usage is uncomfortably high for me and performance generally slow, particularly when:
  -> installing packages or after having installed packages 
  -> when performing file operations
  -> when using Firefox, Libreoffice, etc.
* CPU runs rather too hot (easily at 50 °C or more on average rather than, say, 40 °C)
* network file transfers (rsync, ssh/sftp, etc) are slower than I'm used to

I installed and enabled intel-microcode as well as powerd, as always, using either LXQT or XFCE on the desktop. Although initially the system feels fast, as soon as I start using my regular applications on the desktop, I find that the system slows down considerably to the point where it feels "sluggish" compared to other systems I've used on it.

For instance, after installing papirus-icon-theme (whether manually or through pkgin), I find that it is impossible to change the Whisker menu icon. The icon selector never shows up and xfce4-panel basically just freezes or crashes. This is a resource-intensive operation on any system I've tried with XFCE (papirus is an extensive icon theme after all) but using either 9.1 or 9.2 it would not work.

I have also found that file transfers or network file transfers (e.g. over SFTP/SSH, rsync over SSH, etc) are considerably slower than under other systems I've used. This despite having 'wapbl' enabled on my filesystems. 

Problems also arise when I use applications such as LibreOffice 7 or Firefox ESR. These take up far more RAM than they do under other systems and, apart from that, feel slower and less responsive, at times to the point of actually crashing despite not having too many documents or tabs open. In a sense I could say it leaves me in a state where I can only single-task and multi-tasking is cumbersome, despite not doing anything exceptional. In some cases it actually forces me to shut down and reboot the system.

I am unsure how to explain any of this. RAM handling is different from what I'm used to but I realize it's not necessarily RAM being at play here but just overall performance. Could it be some graphics isue? Could it be the filesystem? I ran all diagnostics on this system and have not found a single hardware problem so I'm at a loss here...

I am attaching my 'dmesg' output for the X250 as well as a few 'top' outputs for your reference. Please do not hesitate to let me know what else you may need.

Thank you.

Attachment: dmesg.output
Description: Binary data

Attachment: top.output_powerd
Description: Binary data

Attachment: top_cold-boot.output
Description: Binary data

Attachment: top_firefox-etc.output
Description: Binary data

Home | Main Index | Thread Index | Old Index