NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

re: port-sparc64/54810: sparc64 pool_redzone_check errors during install

The following reply was made to PR port-sparc64/54810; it has been noted by GNATS.

From: Andreas Gustafsson <>
To: matthew green <>
Subject: re: port-sparc64/54810: sparc64 pool_redzone_check errors during install
Date: Sun, 25 Oct 2020 09:24:05 +0200

 matthew green wrote:
 > > Does anyone have an idea how the mere presence of ntfs in the kernel
 > > can trigger this bug, without an ntfs actually being mounted?
 > there are probe-mounts for root, it may have be called to try
 > to mountroot before ffs was.  does the log have eg:
 >    boot device: re0
 >    mountroot: trying ffs...
 >    mountroot: trying ext2fs...
 >    mountroot: trying nfs...
 >    nfs_boot: trying DHCP/BOOTP
 > where it says ntfs somewhere?
 No, the string "ntfs" does not appear in the console output.
 I tried adding a printf("ntfs_init\n") to ntfs_init(), and it was
 called early in boot:
 [   1.0000000] entropy: no seed from bootloader
 [   1.0000000] ntfs_init
 [   1.0000000] mainbus0 (root): OpenBiosTeam,OpenBIOS: hostid 80123456
 I then tried commenting out all the other code in ntfs_init(), leaving
 only the printf, but that changed nothing; I still got the panic in
 pool_redzone_check during set extraction.
 Andreas Gustafsson,

Home | Main Index | Thread Index | Old Index