NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-i386/55113: Vortex86EX2 based board crashes on reboot

Tried rebooting with Vortex86DX3 in ACPI mode, it didn't crash, so
problems between two SoCs are very likely unrelated. EHCI timeout in
VortexEX2 coming even without anything attached (unless board has
something hidden, but I don't see any candidate). Plus, I also
realized from dmesg messages that Vortex86EX probably doesn't have
ACPI enabled (or ACPI support at all), thus those ACPI errors are
coming from this. So, possibly error messages are related to eventual
crash on reboot. Will try to enable some debugging to see if anything
more will come up.

On the side note is there any ideas on the best way to change
cpu_probe_vortex86 to include 0x38504d44 as EX2? Thanks.

On Fri, Mar 27, 2020 at 12:00 PM Andrius V <> wrote:
> Actually I included full dmesg in bug report unless something more may
> come with different build options? Except number of "ehci_sync_hc:
> timed out" messages everything else seems to be as "usual". This
> message comes only if something (non keyboard) is physically attached
> to USB (and it fails to attach). These messages probably caused by the
> same issue as PR 53894 in Vortex86DX3 (as much as I tried to
> investigate last year, USB transfer  was timing out, which in turn
> calls ehci_sync_hc and it is timing out as well). Possibly reboot
> issue is related and this bug may be a duplicate. I should try to
> somehow to reproduce this on Vortex86DX3 in ACPI mode too
> (unfortunately, on ACPI mode I've never done proper reboot/shutdown
> since both network and USB doesn't work and I can't interact with
> system in any way and system is autopower without power button, but I
> probably can schedule a cron job).
> Parts from dmesg:
> ohci0 at pci0 dev 10 function 0: RDC Semiconductor R6060 USB OHCI (rev. 0x15)
> ohci0: interrupting at irq 5
> ohci0: OHCI version 1.0, legacy support
> usb0 at ohci0: USB revision 1.0
> ehci0 at pci0 dev 10 function 1: RDC Semiconductor R6061 USB EHCI (rev. 0x09)
> ehci0: interrupting at irq 5
> ehci0: EHCI version 1.0
> ehci0: 1 companion controller, 2 ports: ohci0
> usb1 at ehci0: USB revision 2.0
> ....
> uhub0 at usb0: NetBSD (0x0000) OHCI root hub (0x0000), class 9/0, rev
> 1.00/1.00, addr 1
> uhub0: 2 ports with 2 removable, self powered
> uhub1 at usb1: NetBSD (0x0000) EHCI root hub (0x0000), class 9/0, rev
> 2.00/1.00, addr 1
> uhub1: 2 ports with 2 removable, self powered
> ...
> ehci_sync_hc: timed out
> ehci_sync_hc: timed out
> ehci_sync_hc: timed out
> ...
> On Fri, Mar 27, 2020 at 9:05 AM Martin Husemann <> wrote:
> >
> > The following reply was made to PR port-i386/55113; it has been noted by GNATS.
> >
> > From: Martin Husemann <>
> > To:
> > Cc:
> > Subject: Re: port-i386/55113: Vortex86EX2 based board crashes on reboot
> > Date: Fri, 27 Mar 2020 08:01:52 +0100
> >
> >  Can you show the dmesg part(s) about ehci attching? I guess there is an
> >  error message in there.
> >
> >  Martin
> >

Home | Main Index | Thread Index | Old Index