NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: lib/53003: Problem with rust library using kqueue

The following reply was made to PR lib/53003; it has been noted by GNATS.

From: (Christos Zoulas)
Subject: Re: lib/53003: Problem with rust library using kqueue
Date: Sat, 10 Feb 2018 20:30:29 -0500

 On Feb 10,  4:40pm, ( wrote:
 -- Subject: lib/53003: Problem with rust library using kqueue
 | >Number:         53003
 | >Category:       lib
 | >Synopsis:       Problem with rust library using kqueue
 | >Confidential:   no
 | >Severity:       serious
 | >Priority:       medium
 | >Responsible:    lib-bug-people
 | >State:          open
 | >Class:          support
 | >Submitter-Id:   net
 | >Arrival-Date:   Sat Feb 10 16:40:00 +0000 2018
 | >Originator:     Mickaël Viey
 | >Release:        pkgsrc-2017Q3
 | >Organization:
 | >Environment:
 | NetBSD 7.1 (GENERIC.201703111743Z) amd63
 | >Description:
 | Hi,
 | I experiment a problem with using rust Library which use lib kqueue. This library ( fails with an assertion eror about EV_ERROR kqueue constant.
 | The error occurs at line 118 of this file .
 | I reproduce for convenience the related assert test here:
 | debug_assert_eq!(change.flags & libc::EV_ERROR, libc::EV_ERROR); 
 | I tried in FreeBSD the same library and I don't get this error.
 | Could you please help me with your point of vue about this behaviour ?
 | is this behaviour seems to you expected in Net BSD ?
 | I made an issue report on github repo of a lib using mio:
 | >How-To-Repeat:
 | You could reproduce this with:
 | installing rust from official site:
 | curl -sSf | sh
 | then you could test this code here:
 Works in current and I think it will also work in 8. Can you please try that?
Ok, the NetBSD in that I tried this code is my usual working machine, but I will try on a VM ASAP.

Do you know why this code fails on the stable version? (a link to a PR by example)

Thanks for your reply(, and sorry for the typing error on uname.)

Home | Main Index | Thread Index | Old Index