NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

install/46893: sysinst(8) sets up an invalid disk layout

>Number:         46893
>Category:       install
>Synopsis:       sysinst(8) sets up an invalid disk layout
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Sep 03 08:30:00 +0000 2012
>Originator:     Roy Marples
>Release:        6.0 RC1
NetBSD 6.0_RC1 NetBSD 6.0_RC1 (GENERIC) amd64
I bought a Shuttle XS35 702. I started a PXE install of NetBSD-6.0 RC1 and 
selected all default options aside from custom sets to install. Installation 
was flawless, but upon reboot I was greated with a message "NetBSD MBR: No 
operating system found".

I've uploaded screenshots of fdisk and disklabel output from the faulty install 

Also, a support excerpt from Martin Husemann

On Thu, Aug 30, 2012 at 12:24:51PM +0200, Martin Husemann wrote:
    Disk: /dev/wd0d NetBSD disklabel disk geometry: cylinders: 310101, heads: 
16, sectors/track: 63 (1008 sectors/cylinder) total sectors: 312581808 BIOS 
disk geometry: cylinders: 1023, heads: 255, sectors/track: 63 (16065 
sectors/cylinder) total sectors: 312581808 

Ok, I now got what jak was trying to explain to you:

the BIOS disk geometry is invalid, 255 heads is an impossible value (it needs
to be between 1 and 16). I can not emulate this geometry with qemu, as it
rejects this invalid configuration.

So: something must be wrong in the bootblocks (which pass this entry to the

Can you please file a PR?

I worked around the problem by using a NetBSD 5.1.2 INSTALL kernel to setup the 
disklabel and format it to FFSv2. Once this was complete, I changed back to the 
NetBSD 6.0 RC1 INSTALL kernel and it worked just fine.

Home | Main Index | Thread Index | Old Index