NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/46892: panic on `raidctl -u raid0' during reconstruction

>Number:         46892
>Category:       kern
>Synopsis:       panic on `raidctl -u raid0' during reconstruction
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Sep 03 02:35:00 +0000 2012
>Originator:     Taylor R Campbell <>
>Release:        NetBSD 6.99.10 from earlier this month
Architecture: amd64
Machine: amd64

        I configured raid0 with a mirror of wd0 and wd1 following the
        guide in <>.

        I failed wd0 with `raidctl -f /dev/wd0a raid0', began
        reconstruction with `raidctl -R /dev/wd0a raid0', and then
        tried to stop the reconstruction.  `raidctl -f /dev/wd0a raid0'
        didn't do it, so I tried `raidctl -u raid0', at which point the
        system panicked (ten-fingered stack trace, and I'm too tired to
        copy down everything, but this should be good enough):

                # raidctl -u raid0
                raid0: waiting for reconstruction to stop...
                raid0: reconstruction failed.
                panic: pool_destroy: pool busy: still out: 7
                rf_ShutdownList() at netbsd:rf_ShutdownList+0x27


        raidctl -f /dev/wd0a raid0
        raidctl -R /dev/wd0a raid0
        raidctl -u raid0


        Yes, please!

Home | Main Index | Thread Index | Old Index