NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-amd64/45197: failing to load secondary boot

>Number:         45197
>Category:       port-amd64
>Synopsis:       primary bootstrap can't load secondary from hard drive
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-amd64-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jul 31 15:45:00 +0000 2011
>Originator:     Dan McMahill
>Release:        NetBSD 5.9.55
System: NetBSD computery 5.9.55 NetBSD 5.9.55 (GENERIC) #0 Tue Jul 26 23:38:21 
UTC 2011
Architecture: x86_64
Machine: amd64
Downloaded a recent ISO from the releng server.  Burned a CD.  Booted the
CD and did a fresh install onto a brand new hard drive.  The install went
find as near as I could tell (looked just like any other sysinst install I
have done over the years with some of the normal progression of sysinst).
Used the whole hard drive for netbsd.  

After completing the install, I removed the CD and tried to boot from the hard
drive.  The primary bootstrap loaded and ran.  But the primary bootstrap
fails to load the secondary.

The message left on the screen is:

Fn: disnk
NetBSD MBR boot

NetBSD/x86 ffsv1 Primary Bootstrap
Boot failed (errno 5): Can't open /boot

Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key

I rebooted from the CD and mounted wd0a to /mnt.  I then verified that
/boot, /usr/mdec/boot (those are on the CD) both are identical and match
/mnt/boot and /mnt/usr/mdec/boot.  So my secondary boot program are all
there and should be ok.  

fdisk wd0

shows NetBSD for partition 0 and the others (1-3) unused.  For partition
0, it says

  start 63, size 976773105 (476940 MB, Cyls 0-60801/80/63), Active

I tried re-running installboot manually with:

installboot -v -o timeout=20 /dev/rwd0a /usr/mdec/bootxx_ffsv1

If I boot from the CD into the boot program and just type
 "dev", I see:

 disk hd0 size 465 Gb
 disk hd1 size 74 Gb
   hd1a(NTFS) hd1b(NTFS)
 disk fd0
 disk fd1
 default cd0a

The 465 Gb one is the SATA drive I did the install on.  Shouldn't
I see hd0a listed since there is a FFS partition there?  Is there
some chance that the primary bootstrap is not able to figure out
how to actually access this drive?  That could explain why it fails
to load the secondary.

If I boot into sysinst, pull up the utility menu and then run
/bin/sh I can run disklabel wd0 and see that wd0a is 4.2BSD. 
Not sure why the "dev" above didn't show hd0a.  Also trying

     boot hd0a:netbsd

     fails with

     open hd0a:netbsd:  Input/output error
     boot: hd0a:netbsd; Input/output error

I did get an erratum 101 on CPU0 so I'll try to find a bios upgrade.  Is
there any chance that is related to this problem?

the bits of dmesg which correspond to the sata drive are:

satalink0 at pci1 dev 11 function 0: Silicon Image SATALink 3114 (rev. 0x02)
atabus0 at satalik0 channel 0
wd0 at atabus drive 0
wd0: <ST3500413AS>
wd0: drive supports 16-section PIO transfers, LBA48 addressing
wd0: 465 Gb, 969021 cyl, 16 head, 63 sec, 512 bytes/sect x 976773168 sectors
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 6 (Ultra/133)
wd0(satalink0:0:0) using PIO mode 4, ultra-DMA mode 6 (Ultra/133) (using



Home | Main Index | Thread Index | Old Index