NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-amd64/38244: modload pf.o causes unusable console that loops

        Note: There was a bad value `' for the field `Class'.
        It was set to the default value of `sw-bug'.

>Number:         38244
>Category:       port-amd64
>Synopsis:       modload pf.o causes unusable console that loops
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    port-amd64-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Mar 16 02:45:00 +0000 2008
>Release:        NetBSD 4.99.55
  Jeremy C. Reed
System: NetBSD 4.99.55 NetBSD 4.99.55 (GENERIC) #0: Fri Mar 7 
09:06:46 CST 2008 
Architecture: x86_64
Machine: amd64

Here's the kernel:

sudo modload /usr/lkm/pf.o

and my prompt didn't come back.

It showed my console history (which happened to be my green kernel 

I couldn't see what I was typing.

I could press enter and it would scroll and show a new line from my 
previous console history.

So I pressed enter maybe a hundred times and saw:

kernel output (in green)
boot messages and rc.d output again
my login
where I ran modload
kernel output (in green)
and keep looping like that

I had ttyE1 enabled and switching consoles also showed junk on there to 
and unusable.

I tried blindly typing startx and "sudo modunload pf.o" but no change.

Typing "reboot" worked fine.

I can repeat this.

(modload of pf.o on my 4.0 i386 system at console has no noticable side effects)


modload /usr/lkm/pf.o



Home | Main Index | Thread Index | Old Index