Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: xfwm4 crashes on NetBSD 9.99.17 (was "Re: firefox dumping core after NetBSD upgrade")

In my case its also swrast_dri, VirtualBox host. I haven't recently
tried xfce4 on a real hardware with intel, I might di that later.

On Sat, 26 Oct 2019 at 19:25, David H. Gutteridge <> wrote:
> On Sat, 2019-10-26 at 00:40 +0000, wrote:
> > Can someone who has this issue explain it shortly?
> >
> > - Which GPU?
> > - What part of updating (kernel, userland) did it?
> > - Does a clean build of everything fix it?
> >
> > the i915 driver has broken userland compatibility. mrg/riastradh fixed
> > it,
> > but I won't be surprised if there's more we haven't spotted with the
> > high bar of "does startx work".
> I'm seeing it in two contexts:
>  - on a laptop with Intel graphics (presently kernel as of Oct. 15th,
>    userland as of Oct. 13th, pkgsrc has gone through many updates)
>  - in a QEMU VM that has no DRM capabilities (so in that case, xfwm4 is
>    falling back to (kernel and userland as of Oct. 2nd)
> Both were working as of -current's state in mid-August, as I tested the
> xfwm4 update to 4.14.0 on them. Some time between then and early October
> (9.99.15 from a kernel perspective), this issue emerged, it seems.
> I've done a subsequent full update to a -current 9.99.17 plus userland
> from mid-October on the laptop, which hasn't made any difference.
> (The kernel and userland in the VM are from Releng builds.) I haven't
> yet tried a full replacement of every package for either of those
> machines, but I have rebuilt all of Xfce, plus dependencies like gtk3
> and such on the laptop, and that hasn't made a difference. (I
> specifically walked through the dependency chain for xfwm4.)
> My suspicion is this relates to the Mesa update, but I can't say for
> sure. But there seemed to be overlap with the Firefox issue that was
> being discussed.
> Regards,
> Dave


Home | Main Index | Thread Index | Old Index