Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Funky Display Output

Using "modesetting" did clear up the issue.
Keeping the Driver as "intel" and setting "TearFree" to "true" with "AccelMethod" set to "sna" also worked. 
Not sure how this email group looks on adding links to emails. I found some info on TearFree and sna on askubuntu and the Archlinux wiki.

Here's a good resource for explaining a little about TearFree and sna. (archlinux wiki, search intel_graphics#Tearing)

On 4/12/19, 5:08 AM, "Benny Siegert" <> wrote:

    I don't think this is related to xf86. I started seeing these issues
    when upgrading my kernel to the latest version while keeping all the
    userland as is. So I assume it is related to an updated Intel kernel
    I haven't tried but perhaps the "NoTear" option to the Xorg intel
    driver would help?
    On Thu, Apr 11, 2019 at 11:39 PM matthew green <> wrote:
    > i am fairly sure the new display glitches you are seeing are
    > related to the newer xf86-video-intel driver.
    > can people who are seeing issues not related to GL/Mesa try
    > forcing the "modesetting" driver instead?  see if that makes
    > things go away?  i am probably going to revert the driver in
    > -current until someone fixes the new one, and perhaps make
    > the new one optional since it works better for me on
    > kabylake, but it would be nice to know if modesetting helps
    > fix some problems.
    > thanks.
    > .mrg.

Home | Main Index | Thread Index | Old Index