Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

VirtualBox mouse problem


I recently updated my virtualbox netbsd installation to 8.99.18, but
this caused the mouse to stop working correctly.

Before update the mouse worked correctly (well, almost correctly: buttons
6 and 7 were somehow mapped to scroll up and down) in X11 with X11 "mouse"
driver using /dev/wsmouse with
wsmouse0 at pms0 mux 0
wsmouse1 at vboxguest0 mux 0

with VirtualBox 5.2.6 and vboxguest kernel module being compiled from
VirtualBox 5.2.4 sources with a few patches from VirtualBox HEAD.

After netbsd update the mouse is useless as follow: the X11 cursor follows the
mouse correctly across the screen when the mouse is moved, but somehow the
cursor position is still not registered for X at all. For example if I start xev
from a terminal and move the mouse cursor over the xev window no events are
printed to the terminal. And when a mouse button is pressed the event seems to
occur at bottom right corner of the screen (or beyond it?) regardless of where
the cursor appears on the screen. Another example: running XFCE4 desktop,
and pressing right mouse button, the desktop menu opens always at the bottom
right. Moving the mouse cursor over the menu entries does not highlight any
menus, and pressing the left button over some entry does not do anything.

Any ideas?

xorg.conf for mouse has simply:

Section "ServerLayout"
        InputDevice    "Mouse0" "CorePointer"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
    Option      "Device" "/dev/wsmouse"
        Option      "ZAxisMapping" "4 5"

If I use /dev/wsmouse0 the mouse works correctly, but of course very
slowly without the virtualbox kernel module helper.


Home | Main Index | Thread Index | Old Index