Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ixg tester needed (was Re: Problems with netbsd-8 RC1 and ixg drivers (?))


I have tested the the patch with netbsd-8. The problem is not solved.


On Mon, 28 May 2018, Masanobu SAITOH wrote:

Date: Mon, 28 May 2018 17:10:02 +0900
From: Masanobu SAITOH <>
To: Martin Husemann <>,,
Subject: ixg tester needed (was Re: Problems with netbsd-8 RC1 and ixg drivers

On 2018/05/28 16:51, Martin Husemann wrote:
On Mon, May 28, 2018 at 09:46:21AM +0200, wrote:

At the weekend I tried to update to a current version of netbsd-8 rc1.

After the restart, the kernel will work for a few hours. After that, no
packets will arrive at the network card.

Please try the following patch who are using ixg(4) on netbsd-8 or -current:

This change might fix RX stall problem. If you got TX device timeout or
RX stall,  please report with the output of:

	sysctl hw |grep ixg


The server is running normally. No
hints in dmesg.

Some network programs report issues:

zebra[371]: rtm_write: write : No buffer space available (55)

syslogd[541]: recvfrom() unix `/var/run/log': No buffer space available

gate zebra[1423]: routing socket error: No buffer space available

You are seeing two different issues here. The "No buffer space" is considered
harmless (it used to be silent, but the lossage should be the same).

The ixg(4) stops receiving packets is under investigation, RC2 is waiting
for a proposed patch being tested.


               SAITOH Masanobu (

Home | Main Index | Thread Index | Old Index