Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: "bootinfo too big" netbooting amd64-8.0_BETA?

On Sat, 27 Jan 2018, John D. Baker wrote:

On Fri, 26 Jan 2018, John D. Baker wrote:

I've bumped BTINFO_MAX to 64 and added the printf().  Once the build
completes I'll try with the modified pxeboot_ia32.bin.

I haven't tried with the machine I originally wrote about as I can't
arrange the downtime yet.

I have tried with other machines that have, to date, had no problem.
One thing I discovered is that the "/boot.cfg" all the others were
using did NOT load the "scsiverbose" module, while the one that had the
problem did.

Thus the output of the debug printf() was instructive:


Thanks for all of this! It confirms that we're at the edge of the current limit.

Once you can confirm that increasing the limit does not break anything else, let me know and I can update BTINFO_MAX

| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:          |
| (Retired)        | FA29 0E3B 35AF E8AE 6651 | paul at whooppee dot com   |
| Kernel Developer | 0786 F758 55DE 53BA 7731 | pgoyette at netbsd dot org |

Home | Main Index | Thread Index | Old Index