Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: "bootinfo too big" netbooting amd64-8.0_BETA?

Hmmm.  Can you provide the [module load messages] segment?

I'm not too familiar with the boot mechanism, but it is possible that changes in modules' "require" lists could be resulting in more info being stuffed into the bootinfo structure. Did it generate messages for _all_ modules specified in boot.cfg ?

Also, have you tried -current to see if the same problem exists?

On Thu, 25 Jan 2018, John D. Baker wrote:

On a machine that normally runs amd64-7.1_STABLE from local disk, I used
to be able to netboot (PXE) an 8.0_BETA kernel and operate via NFS root.
I have "-obootconf,modules" enabled in the "pxeboot_ia32.bin" I use
(from i386-8.99.7).

After some time of not doing so, I again tried netbooting that machine
today.  It did not succeed.  I observed the kernel segments loading,
followed by the various modules specified in the machine's NFS-resident
"boot.cfg" file, then:

[kernel segments]
[module load messages]
bootinfo too big
Boot fail

Other machines netboot with this arrangement just fine (normally
booting -current).

The particular machine in question has a large number of hard disks
(nine of them, 1x9GB + 8x1TB ).  Might that have something to do with

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645


| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:          |
| (Retired)        | FA29 0E3B 35AF E8AE 6651 | paul at whooppee dot com   |
| Kernel Developer | 0786 F758 55DE 53BA 7731 | pgoyette at netbsd dot org |

Home | Main Index | Thread Index | Old Index