Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Hanging at shutdown with mystery "file system full" error

On Wed, Oct 21, 2015, at 09:57, Patrick Welche wrote:
> On Wed, Oct 21, 2015 at 07:21:58AM +0200, Ian D. Leroux wrote:
> > On Tue, 20 Oct 2015 21:18:51 +0100 (BST) Robert Swindells
> > <> wrote:
> > > Are any filesystems using tmpfs ?
> >
> > /tmp, /dev and /var/shm are all tmpfs mounts.  If I manually unmount
> > /tmp and /var/shm before shutting down, I still see the hang. I
> > haven't tried unmounting /dev yet.
> >
> > > I saw the same problem on one of my systems, I fixed it by backing
> > > out the last change to /etc/rc.d/swap1:
> > >
> > > <>
> >
> > I've commented out the relevant lines in swap1_stop() and now my
> > laptop reboots normally.  My guess is that swap1_stop() first
> > forcibly unmounts /dev, and then tries to remove block-type swap
> > devices (and generally carry on with shutdown) once /dev/wd0 no
> > longer exists.  This can't be sane.
> But you say you see the hang even when you unmount (/tmp and /var/shm)
> and not /dev.
> So the issue is unmounting /var/shm ?

I'm not sure how that follows.  Unmounting /var/shm by hand before
shutting down doesn't prevent the hang, so it's not the absence of
/var/shm in and of itself that causes a problem.  Also, I haven't tried
unmounting /tmp and /var/shm separately, so for now I can't say anything
about one that doesn't also apply to the other.

Tonight I'll try shutting down with various combinations of tmpfs
filesystems, to see if I can actually narrow down the problem to a
specific mount point.

> I am running 12 Oct code without hangs - is this a new problem since
> an update for you?

It's new since an update on Oct. 17th, but my last update was sometime
at the beginning of 2015, so that doesn't tell us much.


Home | Main Index | Thread Index | Old Index