Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Hanging at shutdown with mystery "file system full" error

On Wed, Oct 21, 2015 at 07:21:58AM +0200, Ian D. Leroux wrote:
> On Tue, 20 Oct 2015 21:18:51 +0100 (BST) Robert Swindells
> <> wrote:
> > 
> > "Ian D. Leroux" <> wrote:
> > >With sources from Oct. 17th I get a repeatable hang whenever I
> > >shutdown my laptop (NetBSD/amd64 current).  If X is running at
> > >shutdown time, then I can't switch back to the console (Ctrl-Alt-F1
> > >has no effect) and my only recourse is to kill the power.  If X is
> > >not running I can switch to the console and see that the last
> > >messages to the console are kernel (green) warnings of the form
> > >
> > >uid 0, pid 1, command init, on /var: file system full
> > 
> > Are any filesystems using tmpfs ?
> /tmp, /dev and /var/shm are all tmpfs mounts.  If I manually
> unmount /tmp and /var/shm before shutting down, I still see the hang.
> I haven't tried unmounting /dev yet.
> > I saw the same problem on one of my systems, I fixed it by backing out
> > the last change to /etc/rc.d/swap1:
> > 
> > <>
> I've commented out the relevant lines in swap1_stop() and now my laptop
> reboots normally.  My guess is that swap1_stop() first forcibly
> unmounts /dev, and then tries to remove block-type swap devices (and
> generally carry on with shutdown) once /dev/wd0 no longer exists.  This
> can't be sane.

But you say you see the hang even when you
unmount (/tmp and /var/shm) and not /dev.

So the issue is unmounting /var/shm ?

I am running 12 Oct code without hangs - is this a new problem since
an update for you?



Home | Main Index | Thread Index | Old Index