Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Networking issues with -current?

On Fri, Dec 27, 2013 at 07:07:51PM -0800, Paul Goyette wrote:
> On Wed, 25 Dec 2013, Manuel Bouyer wrote:
> >On Tue, Dec 24, 2013 at 07:02:47PM -0800, Paul Goyette wrote:
> >>[...]
> >>Since the machine that hangs is my primary machine, I haven't yet
> >>taken the opportunity to start debugging.  If anyone has any clues
> >>on what to look for, please let me know.
> >
> >the first thing I would look at is netstat -m and vmstat -m, to see if there
> >are mbuf allocation failures.
> OK, just had another incident.
> Under normal operations of this machine, I have about 530-540 mbufs
> in use (as reported by netstat -m).  When it "hung", I had 899 in
> use, and a "ping" to a local neighbor reported "no buffer space
> available".
> Interestingly, "vmstat -m" reported zero failures.
> BTW, what are "calls to protocol drain routine"?  These seem to go
> up very slowly over time, and there were 18 at the time of the
> failure.
> I tried again to "ifconfig wm0 down" and the process hung.  I tried
> to switch back to another xterm session, and it was unable to
> re-draw the window.

Ha, wn(4). I'm seeing simmilar issues on, see kern/48476.

Manuel Bouyer <>
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index