Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD-HEAD amd64 refuses to build

> On Sat, Dec 28, 2013 at 01:07:45PM +0000, Thomas Mueller wrote:
> > After clearing src tree, but saving and putting back CVS subdirectory, I 
> > was able to redownload the src tree.

> > I was then successful (?) building and installing NetBSD-current for i386 
> > and amd64, building from amd64.

> > But the resulting installation proved nonbootable; apparently init died.

> > I tried
> > boot netbsd-sandy7 -c
> Just to ask the obvious: did you try without the -c, and if so, what
> happened?
> Patrick

Sure I tried without -c, went into the debugger prompt.  

I remember trying -c before on NetBSD 6-STABLE previously with same result, 
uc> (followed by rectangular cursor with blinking horizontal stripes)
and no response to anything from the keyboard.

I thought xhci might be the snag, but subsequently figured the fault was 
probably somewhere within userland rather than the kernel.

I see I have a live USB stick with NetBSD 6.99.11 i386, made from a system 
cross-build from FreeBSD.

I might be able to use that if I try to build NetBSD-current again, also have 
more-recent USB-stick installations of NetBSD 6.1_STABLE, i386 and amd64.

I could also try to cross-compile from FreeBSD but would want to use a newer 
GCC from ports as opposed to 4.2.1 in the base system.

Now on amd64 and i386, with releng-10, GCC is by default not built for FreeBSD 
base system, clang taking its place, but various releases and snapshots of gcc 
are available in the ports.


Home | Main Index | Thread Index | Old Index