Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Port i386 will not build with MKDTRACE=yes

At the request of Mattias Scheler (tron@), I took a quick look at the build for i386 with ' -V MKDTRACE=yes release'. There is a problem with nbtool_config.h

Early in the build, we (allegedly) create this file:

dependall ===> compat
mkdir -p  include/sys   include/machine   include/rpc   include/arpa
rm -f config.cache
CC=cc CFLAGS=-O LDFLAGS= /bin/sh /build/netbsd-local/src/tools/compat/configure --cache-file=config.cache
configure: creating cache config.cache
checking for gcc... cc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking if fparseln seems to work... yes
updating cache config.cache
configure: creating ./config.status
config.status: creating
config.status: creating nbtool_config.h
#    create  compat/atoll.d

The build continues, and at some point later, nbtool_config.h is installed:

#   install  
/build/netbsd-local/obj/i386/tools/binstall/xinstall -c  -r nbtool_config.h 

Yet the file is not found when building ${TOOLDIR}/libelf

#    create  libelf/elf_begin.d
/build/netbsd-local/tools/x86_64/i386/bin/nbhost-mkdep -f elf_begin.d --      
-I/build/netbsd-local/tools/x86_64/i386/include/nbinclude -DLIBELF_TEST_HOOKS 
 fatal error: nbtool_config.h: No such file or directory
compilation terminated.

The error is apparently not considered fatal during mkdep, since the build continues and gets the same error for everything else in the directory.

Eventually, we try to actually compile things, and the same error occurs (and this time it is fatal):

#   compile  libelf/elf_begin.lo
cc -O -I/build/netbsd-local/src/tools/libelf/../compat -I/build/netbsd-local/src/tools/libelf/../../external/bsd/libelf/dist -I/build/netbsd-local/tools/x86_64/i386/include/nbinclude -DLIBELF_TEST_HOOKS -DHAVE_NBTOOL_CONFIG_H=1 -D_FILE_OFFSET_BITS=64 -I/build/netbsd-local/tools/x86_64/i386/include -I/build/netbsd-local/tools/x86_64/i386/include/nbinclude -c -o elf_begin.lo.o /build/netbsd-local/src/tools/libelf/../../external/bsd/libelf/dist/elf_begin.c
 fatal error: nbtool_config.h: No such file or directory
compilation terminated.
*** [elf_begin.lo] Error code 1
nbmake: stopped in /build/netbsd-local/src/tools/libelf

So, where did it put this file?  And why can't libelf find it?


| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:       |
| Customer Service | FA29 0E3B 35AF E8AE 6651 | paul at    |
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette at |
| Kernel Developer |                          | pgoyette at  |

Home | Main Index | Thread Index | Old Index