Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: nForce430 /dev/sound0: high-pitched high-volume squeak

On Thu, Dec 6, 2012 at 9:36 PM, Brian Buhrow <> 
>         hello.  When you run NetBSD-5.1 on this machine, are you still using
> the hdaudio(4) driver or are you using the azalia(4) driver?  Is the
> azalia(4) driver available in NetBSD-6?  If so, does that make your sound
> work?

I tried azalia(4) on NetBSD-6.

   azalia           driver     builtin    0     -        pci
   compat_linux     misc       builtin    0     -
   compat_ossaudio  misc       builtin    1     -        -

   azalia0 at pci0 dev 16 function 1: Generic High Definition Audio Controller
   azalia0: interrupting at ioapic0 pin 20
   azalia0: host: 0x10de/0x026c (rev. 162), HDA rev. 1.0
   azalia0: codec[0]: Analog Devices AD1986A (rev. 5.0), HDA rev. 1.0
   audio0 at azalia0: full duplex, playback, capture, independent

The same results. Only squeaks and no normal sound.

I also tried two Zaffer's livecd running _the same_ 5.1/i386 kernel
with azalia(4).
With one livecd sound works just fine, with other -- squeaks again.
The real mystic is that 1) in case of Live CDs dmesg output was almost the same
(difference only in wdN lines) and 2) result is 100% reproducible.

On 5.1 _amd64_ that worked for me before update azalia(4) was used.

Home | Main Index | Thread Index | Old Index